Can't update firmware

Hello guys
I just got my de Aeros. The firmware version is 2.2.0, so I try to update it.
It can connect to Wifi, but when I pressed update, it didn’t work. (I found a post that said firmware 2.2.0 has problems with updating via Wifi.)
Then I try to update with SDcard. My SD card is SanDiskt Extreme PRO, it’s 32GB, Class 10, and SDHC. I format it to FAT32 and flow the operating steps.
After lots of trying, the firmware version still shows 2.2.0.

And I noticed that when I plug in my Sdcard, the Songs is still saved in the machine storage but not SDcard. Does it mean that the SD card reader has some problems and that’s why I can’t update?

There’s a 3rd way to update by WiFi. You skip past the first screen asking you to update, and you find the update menu on the Aeros. That update menu usually works.

Hey there, are you renaming the file to “aeros.bin”?

Also be sure you are connecting the SD with the .bin file while the Aeros is powered off. Then, once the SD is inserted, power the Aeros on, it should update.

Thank you.
I have tried the wifi test in update page, it shows timeout. I’m in mainland China currently, I think the IP is banded by the government’s firewall.

Thank you. I solved it.
I have done all steps correctly, and the reason is this SanDisk SD card is not supported by areos though it is 32GB, class 10, SDHC.
I change another class 10 SDHC card, and it works well.