Controlling Boss RC 500 with Midi Maestro

Hello,
New to Midi here. I know that I’m probably overcomplicating things, because it doesn’t seem to be such a complicated procedure on the Youtube videos I’ve watched, but unfortunately, I have not come across a video using the same hardware together as I am. So I’m hoping someone else might be using the Boss RC 500 looper with the Midi Maestro. I’ve got the Midi Maestro and Beat Buddy connected. I got some assistance last week with setting midi controls between the two of those and am up and functioning with them.

I’ve just added a Boss RC 500 looper to the mix and can’t seem to get the looper to recognize the Midi Maestro command that I’ve programmed.

As far as cables, I have the Beat Buddy sync cable with the additional connection that I believe the purpose is to connect the MM, Beat Buddy and Aeros together. However, I am trying to connect the Boss looper using the additional connection on the cable. I’ve also tried a single midi cable from the MM directly to the Boss looper, but have had no luck as well. I also have the official Boss trs midi cable for the looper, so I’m sure this is not a cable issue.

Right now, I’m just trying to do a simple, “start track 1” command. I connected the Singular Sound phone app via bluetooth to the MM and have started a blank “Custom” template, putting that control in.

Can someone please take a look at the settings I have and maybe give me an idea what I’m doing wrong?

On the Beat Buddy, the main pedal settings are:
Midi Channel in—“Omni”, Control change-“enabled”, Program change-enabled
Midi Channel out-“midi merge” is marked. It’s set to channel 2.
The command I uploaded from the phone app to the MM is “Track Start” Device RC 500, Description Start Track 1, Type-(CC)
Channel 2
Command 1
Value 1 (I also tried 0)

On the RC 500, the midi settings are:
In the global “midi” settings (listed under the “menu” button)
“RX Ctr channel” is 2
“omni” is set to on
“RX note channel” is at 10 (I’ve also tried 2). According to something I read, 10 is set by default in the looper, because it has something to do with controlling the drums/rhythm.
“TX channel” is 2
“Sync Clock” is auto
“Clock out” is on
“Sync start” is all
“PC out” is off (i’ve tried off and on)
“midi thru” is set to “midi out” (I’ve tried it set to off as well-the only other options available are off, usb out and midi/usb)----Note-I am not running anything from the midi out port on the RC 500. Just have the cable from the MM and Beat Buddy to the input

In the “memory” settings of the Boss RC 500: “Assign 1” is set to on,
“source” is CC #1
“source mode” is “moment”
“target” is “T1 start”
"target minimum and target maximum are set to “immediate”

Thank you in advance

This has been solved. Thank you.
Hello again,
I’m still battling with getting the Midi Maestro to make control commands on a Boss RC 500 looper, but have had some luck since I made my original post. I think at this point, it’s now down to someone explaining a basic midi command that I can’t seem to figure out. Assistance with this would be very appreciated.

I’ve been able get a start/stop track command between the two to work, but I’m having an issue trying to understand what I need to send from the Midi Maestro to just have a stop track command. I’m trying to set up a pedal on the MM that starts the BeatBuddy on the current song and also, stops track 1 on the RC500.

On a start/stop track command, you need to enter two separate commands on one pedal of the MM. One being the start function with a particular cc# chosen (for example, I’m using cc#1) and a value of 127, on the same channel as the stop function (also using channel 1) and the second command needs to be for the stop portion of it. The cc# is 1 and the value is 0. This works perfectly.

This has been solved. Thank you. Can someone tell me what I need to send from the MM to the RC500 on a stop command only? I’ve tried a number of things, but no luck so far. Do I need 1 or 2 separate commands (like the start/stop command). If I need 2 commands, does the value of the first need to be at 127 or 0? What would the value be on the second? Do I need to do anything special with the press/release function on the commands?

Thank you