Crashes/hangs on multiselect delete

Version: 5.0.1

Tried to delete multiple songs and the Aeros crashe the first time and hung the second time.

The first time I had selected what appears to be a max number of songs (120). Crashed to the splashed screen, but never went past the spash screen after waiting a while. Had to power cycle.

Second time only had 20 songs selected, tried using the right physica button to confirm confirmation prompt to delete which did notthing … as well as any other press. Was hung. Had to power cycle. One odd thing was the multi-select state was “left over” from an accidental “select” and trip to the loop studio. Not sure that matters.

Note: It’s also a bug to not allow selection past a max without a warning/error message.

Note: It’s also a bad idea to label the right button “Select” when you have another action called Multi-Select. In this case recommend the term “Open” or “Load” which better describes the command since you load it and then go to the loop studio.

Thanks for the report

It can take a while to do batch actions sometimes, which possibly could be smoothed but it is possible it was not hung but just in process.

We will look into this

Thanks for the feedback

Possible, but I waited a while.

Worst case, display a progress meter for long operations.