End sections of saved songs go silent

I have an issue where on a couple of my saved songs go silent towards the end.
One song goes silent right at the last bar.
Another song with many more bars goes silent a few bars before the end.
You can see the wave forms but no sound.

Let me guess that the (midi) bpm or time signature has changed since you recorded the song?

I haven’t changed anything. Most of my other saves are working. Just the first two in the video are bad.
The last one wasn’t supposed to be put in the video.

What’s your firmware version?

Firmware is up to date. 4.0.2

Too many issues with the version 4 !

try to downgrade to 3.5.1 to see

I transferred the songs to the card and played the files on my pc. Put the card back in the Aeros and now it works.
I have no idea. I changed the bpm on the BB and it didn’t matter.
Maybe just restarting the Aeros did it.
If it happens again I will do things one at a time to see what may have corrected it.

I’ve had a similar problem and have also let them know about it.

Thank you for reporting, this has happened one time before (at least reported) for an issue that seems to have not been related to clock.

Just in case, please do make sure if you are using a clock (esp the BeatBuddy) that you do not keep the Aeros physically engaged to it if it sends out clock always and is not meant to be guiding the Aeros tempo.

This is because the Aeros does not currently report desynchronization and also does not have an internal decoupling or filtering of the clock. So the Aeros is reacting to the clock always if clock is being received. The BB has a setting by default to send clock always, this improves playback synchronization when the units are working together.

We hope to remedy this situation soon, this behavior is the same reported in these scenarios, let us know if this had any relation.


Brennan, do you think this is behind that issue we’ve been discussing, too? Is our only alternative to just set the tempo manually until this is fixed?

It could be the problem! If you have a clock going into the Aeros and it doesn’t match the Aeros Internal you will experience this issue.

The best solution will have to be allowing the Aeros to decouple from the BeatBuddy’s clock and filter, we are not far from this solution the main problem we have right now is implementation and UI and we are working on that as quickly as possible with our designer.

If you notice that removing the cable physically fixes your issues then it is very likely the culprit. Please let me know if you come across this again for that reason! Or if it happens again for any other reason as well!

Thank you for your patience!

My issue was the clock.

You were right.

Glad you figured it out!