Error "Midi file does not contain any event"

Hello BeatBuddies, I have attached a MIDI file that causes a problem with the BeatBuddy Manager version 1.33. The MIDI file is a simple two bar 4/4 count intro on MIDI note 37 which is usually assigned to cross sticks or rim hit.

If I create a New Song under the Metronome folder, I can import the MIDI file on the Main Drum Loop slot and play it with Rock or Standard drum sets.

If I create a New Song under the Blues or Rock folder, I attempt to import the MIDI file on the Main Drum Loop slot and I get an error dialog box complaining about MIDI parsing with the message “Midi file does not contain any event”.

This MIDI file plays in other MIDI editors and only certain song folder in BB Manager. Can anyone duplicate or explain the problem?
Thanks, Dan

Look, I was about to say that MIDI note 37 is not supported, but it actually is!

I went on to try replicating the issue you are talking about, but I was perfectly able to add your file in a new song in both Blues and Rock folders. Most importantly, this MIDI sample is being played correctly for me.
Are you sure (you know, I’m asking just in case…) you use the latest BBManager version 1.3.3?
Can you import the project to pedal (just to test your project doesn’t have any invalid songs by chance)?

If someone else has this problem, please report. This sounds like how it should never really be.

Thanks for the info. It is weird that it works for you and not me. My setup is definitely BBM 1.33 with standard songs in all the original folders. I put new songs in new folders like “DansSongList”. I can’t really test it on the pedal, because BBM won’t let me create a song or export to the pedal.

I know this may be stupid, but are you sure you are using the exact file you’ve uploaded for me to the forum?

Well, I think you can try this workaround. Try making a totally new project with File > New Project (so BBManager is empty), and try creating the desired song there. After that export the song, open your main project and import your song.

Anyways, what you encountered is a pure bullshit on the BBManager side, and this issue should never come up normally! I would love to fix that, yet I can’t reproduce it :frowning:

Same problem for me.

At the launch of BB manager I can load the file (mine or that of Beckerdo ), but impossible to put a time thereafter without the error message shown above.

Wow… Is there anything specific that you perform after which this starts happening?

Nothing special. I open the manager, I select the midi file for either the intro or for the main part. So far so good. But impossible to select another midi file without the error message appears. The only way to succeed is to close the manager and then open it a gain. With some midi files I do not have this problem, but I have the problem with files that worked well before the 1.33 update.

FYI, I found that if I take my Reaper MIDI editor exports, and open and save them with the open source MidiEditor (, they no longer have the error message. For all those debuggers out there, attached is a version of the file saved with MidiEdit. You can compare that to the Reaper file attached to the original post and see what is the difference that causes BB Manager 1.33 to barf.

Thanks, Dan

Beckerdo thank you, I followed a similar procedure to solve the problem on my side. I usually use Anvil Studio to build my midi files. Once built, and I open my backup files with Sonar and I have no more error message.

The placing of my files by Sonar before putting them in the BB manager also solved a problem I had with the application for iPad DrumStudio. To make midi files this application is the most user-friendly I could find so far, but the BB manager did not see the first shot drum. So it was unusable. But through Sonar (and I imagine it would be the same with MidiEditor) the problem is solved.

Management midi files seems a little difficult for the manager BB. Ideally, and I think Singular Song know, it would take onboard midi editor at BB manager.

Sorry for the broken English, I use Google Translate.

That’s indeed admirable. Thanks for that!