Footswitch 2 Has a Mind of Its Own!

Greetings from a new member. New pedal, latest software, my own 2-button momentary contact external pedal. TRS stereo male plug into BB jack. Everything ohms out perfectly. BUT… In spite of everything I try, the #2 switch can’t decide to work or not work. When not working, the Footswitch Detector doesn’t see it, and when working, it does see it. I do not believe it’s the jack in side of the BB, or my cable. I can always get the thing to temproarily work by doing one of two things:

  1. One, or sometimes several, or sometimes many re-seats of the TRS cable at the side of the unit. Or,

  2. One, or sometimes several, or sometimes many power resets of the unit. If I power reset the unit without touching anything, often times it will suddenly start working.

Problem is 100% unpredictable, and truly doesn’t seem to be hardware, unless there is a loose solder joint in the unit, or some other kind of non-software gremlin. I feel as though this could be either a firmware bug, or some sort of problem in the guts of the unit; of course, I’ve been wrong before! Anybody else seeing this? Would temporarily rolling back the software possibly be worth trying?

Windows 10 PC; BeatBuddy FW version 2.0.4-RC4

Most likely not a firmware problem or other users would be reporting this issue too. You could try reinstalling the firmware.

Try another TRS cable and apply the foot switch detection setting. Make sure cable is firmly seated in the pedal and the foot switch jacks.

You might also check the foot switch wiring to the jack and switches (cold solder joints, etc).

Update: On a hunch (former Field Engineer, and I’ve actually seen this kind of strange behavior before), I decided to modify the cable to include an inline connection for Switch 2; a male mono 1/4 on the switch-housing end, and a female 1/4 mono on the other, to isolate a possible jack problem on the BB unit. Sure enough, I can duplicate the problem (and the temporary fix) by re-seating the inline connection. So now I am more convinced that the BB jack itself is probably not the issue here. Still thinking maybe firmware (I hope, at least) is somehow involved. Would love to hear from others; thanks.

Thanks, persist. So then I can be pretty sure that this is an isolated problem? I will give a FW re-install a try and then, in worst case, go buy another stereo male plug and get out the darn soldering iron again.

If you need a picture of how the pedal is wired, let me know

Yeah, at this point, I would agree that it’s better safe than sorry. I’ll take it; thanks.

I may have it surrounded now. Maybe a high-ohm connection at the BB input. I can visibly see that the male stereo connector that I bought for this project I built is shorter than another connector that I have (one that’s connected to a pair of headphones I have laying around). I measured them with calipers, and, sure enough, the one I bought is exactly 1mm shorter than the other. I was under the impression that the “Hosa” company made good stuff; I guess I was wrong. Anyway, I guess the next step is to put a different connector on.

I will take that drawing though, if it’s not too much trouble!

Done. Strange as it seems, it looks like the 1mm shorter length of the Hosa connector was just enough to cause my trouble. at least that’s what I’m going to blame it on. Whatever the cause, replacing my internet junk part with a different stereo male 1/4" end connector seems to be the fix. I’ve gone from 100% unreliable to (as far as I can tell at the moment) 100% reliable. Case closed. I think. Thanks, persist!

Thanks for letting me know

I am having the same or a similar problem. Just got my BB and BB footswitch today. I uploaded the current firmware - 2.0.4-RC4. Followed instructions for footswitch detector… BB screen said “Press and release left footswitch.” I did and got nothing. So I pressed the right footswitch. So screen said “Press and release right footswitch.” I did and it said “No right pedal detected.” Then it gave a status: Momentary & Normally Off. I had to reset everything to factory. Have done this an number of times.

I’ve tried everything I can think of. I am using the TRS that came with the BB footswitch. Everythiong is brand spanking new.

If the TRS cable is fully seated in both jacks and in the foot switch jack, only quick check I can suggest is to try another TRS cable. What does the configuration setting say?

Momentary/normally off (the latest firmware has no separate menu to look for the config). Yes, I have tried 3 other stereo (TRS) cables. I believe it must be the jack inside the BB, not the one inside the BB footswitch. I say this because I have reinstalled the latest firmware and I am assuming there are no bugs in it. Also, I’ve looked inside the BB FS and I can see no solder problems. A jack is a jack is a jack. Pretty simple. So, I don’t think there are problems inside the BB FS. However, I am reluctant to open the BB itself. I assume it is more complicated in there. If it is indeed a problem inside the BB, then I guess I will have to return it to GC (I ordered online, so I hope they will accept it at a store).

Something to try before you return it:

  • revert to firmware version 1.8.5 and see if that works; if it does,
  • reinstall 2.0.4 and test one more time

If you have a recent BB pedal, it probably has the warranty seal on one of the baseplate screws and if you remove that, it might cause GC to not honor the warranty.

Good luck with getting it resolved. If you’re still having problems, contact Support

Thanks! I will try (and I won’t open the BB pedal :-). Can you provide a link to ver. 1.8.5? I only find the latest version on the main site.