Gap in audio playback on first part, but waveform shows on screen

I started using my MM,BB and Aeros together, and everything syncs ok but… in 2x2 mode, when I record my first track (started from MM and record starts after BB intro) I record 4 bars then I switch to play mode. I then get a gap in the sound about halfway through the fourth bar, and no sound till the start of the first bar,EVEN THOUGH A WAVEFORM IS SHOWING ON THE SCREEN.
This seems to be intermittent, as I had this problem initially about a week ago, but then it went away.
Any ideas or is this a bug?
Thx, Andy

It’s likely a known problem where the tempo that the BB is currently sending is different than the tempo that the loop in Aeros was originally recorded. I don’t know if there are other reasons for that to happen, but that’s what I have experienced.

I tried to make this clear in a video, but used another Master Clock and not the BB. The problem I’m discussing is still the same though regardless what device is sending Master Clock.

1 Like

Strange, that’s what I thought when I originally had this problem, but now i make sure I erase the song (I only use one song, and erase it before each new song on my gig setlist). This happened when I went to a new song on my Beatbuddy. Is it possible that I have to erase before selecting a new beatbuddy song? I’ll test it later and report back.

Yeah, IDK. IME, this is the primary contributor to why it happens. It would definitely be best if you methodically tested out all the sequence of events that you undertake to find that one repeatable sequence which leads to the problem.

Changed to a different song on my BB, then changed back to the song
I had trouble with, and recorded the song again and it was fine. I cant gig like that, I’ve enough to worry about. I will persevere for a while as there’s still a chance that my newbieness is causing me to find issues. Is this a documented bug?

Hey there, looking at this and we did see some “sticking” of the tempo in some instances in 4.0.1, this should be fixed in the next iteration of 4.2.x which is coming soon. Could you possibly explain what steps you can take to get to this state? If reproducible, we will be able to quickly fix it.

Thanks for reaching out

I switched to a different beatbuddy song, then went back to the beatbuddy song I was having trouble with, and all was ok. Cant remember if i erased the aeros song first or not. I’ll continue to investigate.

I got this gap today(and sometimes)
I played hours with the same BB song tempo 134 bpm
Then I decide to change my mind, and switch to another BB song with another tempo 84
And the gap was there! when erase the song, again and again
I switch to another song and was OK
This issue seems to coming when you switch to another song whatever the song is

I send a video on SS support, maybe this can help, I gonna take more attention when this happend again


Nice video, it clearly explains why you see waveform on the screen, but no sound. I’m going to try and simulate that with my Beatbuddy and aeros to see if that’s whats happening to me. Thanks.

Hi again, when you can please let us know what the specific steps were, it’s possible this has already been fixed in the upcoming version