Get another pitch on playback on Infinity looper?

Really weird.
When I launch my BB and record a loop on Pigtronix infinity looper and launch the playback
The playback is another key? BB change the Pitch sometimes lower, sometimes higher?

If i do the same without the BB, no problem?

You can listen here:
I record a loop and press for the playback

Can anybody help please?


It sounds like the Varispeed on your Infinity is toggled on.

Maybe some of the postings by other users can help you solve the problem.

Thanks Man
I take a look.
But is there anyway to reset the infinity to default settings?
Or maybe I go wrong with the footswitch and start the varispeed on, without thinking about?
But I gonna check all, really weird because yesterday no problem with this?
Sorry for my english ,I speak french

I saw 2 issues
The footswitch did’nt work correctly (both switch was reverse?), I reboot stutter Off, and reboot again stutter on (or reverse i don’t remember)
after the reboot the footswitch work correctly reverse and undo.
Now I saw Fret 9 post and this is what i have , not perfectly stop or start and hell yeah pitch low or higher.I try another way to record and sounds good.

What I did is push the record directly after the intro
What I do now is let the intro playing and play with tempo and when good I push the record and that’s a lot better no more variation

But just one question to be sure ; How do you disable the varispeed for all presets??

Thank you persist

Hi Punkyboy.

  • Do you have version 203 of the firmware installed on your Infinity? If not, you might want to update the Infinity firmware.
  • You can reformat your Infinity by following these steps (I think this will solve the problem with the Varispeed, if it doesn’t please let me know)
    Infinity Looper can be reformatted on boot up. New menu allows the user to select the number of presets / maximum loop time:
    []Pressing and holding the SERIES LOOPS switch while the Infinity boots (directly after the firmware version number displays) will enter a Reformatting Menu (indicated by a lower-case ‘r’).
    ]In this menu, users can select the number of presets to format the Infinity with, in increments of 10: 1=10, 2=20, 3=30 etc.
    []Once the desired number of presets is shown: (since the default is 1, change it to 2–it will give you 20 presets–you can reformat it back to 1 later if you want)
    ]Pressing on the Preset Encoder or the SERIES LOOPS switch will confirm the selection, reformat the Infinity, and reboot.
    [*]Pressing the STOP footswitch will cancel the re-formatting and exit the menu.

Hi persist
Thank you very much for your help!

How can I check my firmware version?
normaly I updtated it, but I never see the “F” on the screen when I update?

I proceed like this:
The Firmware update file should now correctly be located in the LOOPERFW folder of the Infinity’s USB Drive.
7. Eject the Infinity and disconnect the USB Cable.
8. Now Power-Cycle (Disconnect the Infinity’s Power cable and then connect it) while holding down the “INPUT SPLIT“ switch on the Infinity. The Infinity will reboot and begin to firmware update if new firmware has been correctly loaded into the LOOPERFW folder. While firmware updating it will display an “F“ on the 7-Segment LEDs

Bu twhen I hold down the INPUT SPLIT" I get a flashed “A” a long time, and I repress input split to get the “O” the normal stand? do I need to let the “A” flashed longer? And what’s mean with Hold DOWN? stay pressing or just press one time and release?

When you power up the Infinity, in the left window, it displays something like, d, 5 and then one digit at a time e.g. 2-0-3. It also displays on the title bar of the app if you have the Infinity plugged into it.

If you need to update the firmware, go here

Ok I check it tomorrow but I think I see a 3 (but it’s fast)
But just a correction (I correct it in the post below too) Is a flashed “A” (the A is for agging loops)?
I let you know tomorrow
Thanks again persist!
Jesus and there is no Pigtronix forum ?!

Hi persist

exactly what I have on display D 5 2-0-3


That’s good. Have you tried to reformat the Infinity?

No, do I need ? because I’m update?
If I need, do I need to update again or Infinity stay on2.0.3 ?

Hey Punkyboy. If your Infinity pitch is working (no pitch problems), you don’t have to do anything.

If your pitch is not okay and you want to fix that, then you can try to reformat.

Ok I will see
thanks for all persist :wink:

I reformate the looper to be sure and to start properly.
But I see the problem, it’s like fret 9 say on the post (link) below.
i f you not press on the good time, the pitch change
you press to late = the pitch go higher
you press to fast = the pitch go down

'It’s a question of perfect sync with the looper and the BB
But it’s ok now. I got the tip

Thanks for all and your support !

I get the same “A” and don’t know to press input split once or hold down either. Any ideas? Need to upgrade software before I can use BB with pig. Any ideas? Thanks…

Hi, Tobacowes. I take it you’re trying to update your firmware.

Just as an FYI, according to the looper user guide, the flashing A is what’s displayed when you’ve entered the Loop Aging Menu.

There are 2 ways to update your looper firmware. The method above is for a manual upload. The easier way, from the Infinity blog is to use the looper application to automatically update the firmware. I just went back thru the process from the blog and it worked for me. You only have to hold the INPUT SPLIT key until the F is displayed. As soon as the firmware has updated, you should see 2-1-1 flash. Give that a try and see if it works.

I so appreciate you willingness to help me. I hate to be a bother. I have been trying to update the infinity four a week with no success! Will try again tomorrow. Thank you!

Let me know how the firmware update turns out.

Hi Persist! Thanks to you I have encountered success! It took awhile for me to recognize the number sequence stating that the firmware was updated. I was expecting a big 211 to appear in the window, not the quick 2-1-1.

When I pared the pig looper with the BeatBuddy I was disheartened for I noticed that the led light was still flickering on the looper. I then proceeded the turn off the midi clock on the BeatBuddy and guess what!? The flickering stopped! I assume that I am good to proceed. I played in a band for twenty years, twenty years ago. I’m excited to play with a drummer and bass player again! Will try to work problems out before I ask for help… Thank you