Getting Aeros to playback on next beat

Hi – I’m relatively new to the Aeros Loop Studio, but I’ve read the manuals and browsed this forum, and still not found a solution.

I’m using the Loop Studio with a Helix Floor, where the Helix is controlling the tempo via MIDI out. I can record without issue – the looper will start the recording “on” the beat, correctly, and the loop will play in time with beat-sync’d effects on the Helix.

The issue is after I stop the Loop Studio, and start it again. I would expect the loop to start right at the next beat following when I press the play-stop button (similar to clip-playback in Ableton Live), but this is not the case. Instead, the loop starts playing right when I hit the button, which means my timing has to be perfect, in order for the re-started loop to sync-up w/ the beat-synced effects happening on the Helix.

What am I missing?

1 Like

There is definitely something wrong with the MIDI sync being sent by the HX stomp, the problem seems to be that the Aeros is not marking the 1 of the measure as it should, which could be related to a change in the clock stream from the HX, have you done a search of the forum? Likely there has been another person with your issue. Does the Aeros say MIDI sync ON onscreen even when stopped?

Let me know! Thanks

Also please verify you are on latest v3.4.2 for Aeros, thanks!

Not yet on 3.4.2 – still on 3.3.x. I’l try that.

The Aeros always says MIDI sync is “on”…unless I just completely disable the clock out, from the Helix Floor (not Stomp, btw – although they have a nearly identical MIDI implementation).

I’ve definitely searched the forum…but there’s a bit of an issue w/ recall vs specificity…if I make the search terms too specific, I get nothing relevant, and too broad, too many results to wade through.

This kind of thing varies from looper to looper, and I have the same experience as you do with the Aeros (I use a TEMPODE for Clock and Start/Stop). I really don’t think it is how the Tempode is sending Clock, but I could be wrong. I’m basing that on using 3 different loopers and observing how they each work in different ways slaving to the TEMPODE.

If it helps with anyone’s research, this is the behavior of all 3 Loopers that I use (Aeros, 95000, Infinity), and how they are each different in these 2 use cases:

Start/Stop with TEMPODE:
After starting the Tempode and getting a loop recorded in each unit, if I stop with the Tempode, all devices Stop. If I start again with the Tempode:

  • Aeros and the 95000 - start immediately at the 1 of their recorded loops. (the preferred way it should work, IMO).
  • Infinity - does not Start. It recognizes that the Clock is running, but waits for me to press Start on the Infinity. When I press Start, it will wait until 1 comes around and start with it in sync.

Stop/Start directly on the Unit while TEMPODE remains running
Again, I start Tempode and record a loop in each device, everything is in sync. But now I leave the TEMPODE running and just stop any one of the devices on their own. When restarting the device on it’s own (while the TEMPODE is still running):

  • Infinity - same as above. It will wait until the 1 comes around and then start (in this context, this is the way it should work, IMO.).
  • 95000 - It will start on the next clock beat from the top of it’s loop, so it’s in sync tempo-wise, but the 1 can be in a new place in relation to any other devices also keeping sync. (I can work with this, I just have to press Start within 1 beat of when I need it to actually start)
  • Aeros - It just starts exactly when I step on it and can be off the beat entirely, though in sync tempo-wise. (I avoid doing this because it’s too risky)

I’m not sure about the idea that there is a problem with the Clock stream or that the “1” should be marked in the stream itself. Empirical results have always indicated to me that the concept of “1” is determined by the unit receiving the clock, which is why each device can be set for various Time Signatures, even while receiving the same Clock data. I think the first tick received by a device is the ‘1’, and then the Time Signature set on the device is applied from there. In the case of the Infinity, I believe when I stop just the Infinity (the TEMPODE is still running), it is still receiving and processing the clock and internally continues to recognize where the ‘1’ is. The other devices don’t do that when they stop. The 95000 jumps in on the next clock beat and makes that beat the new ‘1’ and the Aeros just jumps in right away, even if it’s in between beats.

1 Like

Interesting, about the relative behaviors of different loopers, @RockDebris. I do recall that my Infinity worked as you describe – and not the way the Aeros is behaving. Another data-point, re: clock-stream: I attached the Aeros to the MIDI out of Ableton Live and conducted the same experiment (this time w/ a loop/song in 1/4) and it behaves basically like the 95000 does. So it seems the presence/absence of “measure” data in the clock-stream definitely seems to matter to the Aeros.

1 Like

Interesting. I guess I’ve never owned a master clock that sends measure data or a device until the Aeros that depends on it. But you say with the Ableton stream that the Aeros behaves basically like the 95000 does, however I’m not clear if that means 95000 is syncing to the next beat (as I stated) or is it actually waiting for the 1 to come around? Because that would also be a difference in how it behaves depending on which external device is used, which would be also good for my personal knowledge. Thanks for testing it out!

I thought I had a basic understanding of this, but this thread was making me question that, so I did some digging. I’m still not 100% certain, so any corrections gladly welcome! It didn’t end up changing my basic understanding, but may have added to it.

The loopers I use each have the ability to set the time signature. And they each recognize MIDI Clock data. MIDI Clock just keeps everything in sync by sending the ticks, but Time Signature is a higher level concept that needs to be managed and can be set by an external command if the looper recognizes it.

So, I THINK the difference in behavior between using one external Clock or another has to do with what the external Clock device is designed to do: Send only Clock and Transport Commands, or also send other sequenced commands? It’s not an error if it doesn’t send other sequenced commands, that’s just not it’s purpose. My TEMPODE is strictly a Clock and Transport. Sound’s like your Helix is strictly a Clock. Ableton however is both Clock and Sequenced commands. Beat Buddy is both a Clock and a Sequenced commands.

And the difference between the loopers is how they have been programmed to react when only Clock data is present and they start up mid-stream.

It would be nice if the Aeros could start up mid-stream like either the Infinity or 95000 does when it is only receiving clock data. It’s not a huge deal to me, kind of an edge case for a guy who is already an edge case :crazy_face: @DavidPackouz ?