Getting the BeatBuddy to work with the Infinity looper

I just purchased the Pigtronix Infinity looper because people have said it synchs the tempo/loop really well to the BB, however, it’s not synching. I have the midi cords hooked up, BB and Infinity firmware updated (it says software 2.11000 while loading the Pigtronix application), and I believe the midi BB settings correct. I’ve read many posts on this but still cannot get them to synch. Not only does it not synch, but the start and stop commands from the BB do not do anything to the looper either. It’s like they are not even connected / talking to each other. Any suggestions?

Check in the settings of the Inifnity . And check like this pic. look at the Midi channel (on the left)!When ready, close the application, EJECT the usb with windows (don’t remove it). Power OFF the looper, remove the USB from the looper and PC.Reboot your looper. Go to Beatbuddy now, In the settings of the BB go to MAIN PEDAL>MIDI SETTINGS>MIDI OUT> Output Type= OUT> Channel (the same as the looper)> SYNC =Always ON> STOP=Pause & End> NOTES=Enable>Time signature=Enable. Now you have 2 way to stop the looper with Beatbuddy If you want to stop the looper when the BB is PAused or let the looper play when Beatbuddy is Paused, depend what you like to choose this go to BB settings>MUTE PAUSE >ENABLE= looper stay playing when BB is paused. DISABLE= Looper stop when BB is paused. AND don’t forget to put the midi cable into the OUT of the BB midi cable

I have matched the settings you provided and the looper is now producing a bad sound during playback. It sounds like it’s fighting for power / dying and kind of metallic. It also randomly stops the looper now (maybe after a measure or two?). I isolated the setting on the BeatBuddy which is causing this: Enabling midi notes. When I select disable midi notes, it does not cause the bad noise, but is still out of synch. I even tried two different 18V power supplies, but it seems to be the BeatBuddy enabling midi notes. I guess they are talking to each now, just not in a good way. Any further advice?

Is this a brand new Looper?
Are the midi cables ok?
Firmware updated? last one is 2.1.8.
You can try replace your microSD card inside the looper, but there is a way to do that
check here is easy to do, just take care for the little metal plate cover up the sd card, you need to slide this plate first, don’t try to remove the Sd card, FIRST unlock the metal cover
https://drive.google.com/file/d/1M7UOyUCBbBJhc53sb24UTUbax4dLN667/view