Getting the BeatBuddy to work with the Infinity looper

Several BeatBuddy users that connect their pedal via midi to their Pigtronix Infinity report that their looper changes pitch or shows latency when starting a song on the BeatBuddy.
After working with Pigtronix on this issue, here are some suggestions for interfacing these pedals via midi:

  1. Make sure the firmware and the apps for both devices are the most current. Although the Infinity firmware is reportedly at 211, after updating, the looper displays 210.

  2. Connect the two pedals using the BB MIDI sync breakout cable; insert a male-to-male 5-pin midi cable between the BB MIDI Out to the Infinity MIDI In (making the BB the master).

  3. Pigtronix suggested trying any one of the options below to improve the functionality of these two devices:

    • Turn off MIDI clock out on Beat Buddy. If you don’t want pitch change but you do want to trigger the START and STOP for the looper, BeatBuddy needs to stop sending MIDI clock and should only send MIDI start/stop commands in order to avoid pitch change in the Infinity. If you need BeatBuddy to send midi clock, then this is not your options (try one of the other 2 options).
      On the BeatBuddy pedal:
      – press Drum Set and Tempo to enter the settings menu
      – scroll to and select Main Pedal
      – scroll to and select MIDI Messages
      – select MIDI-OUT
      – scroll to and select Sync
      – change to Disable and back out of the settings

    • Using the Infinity app, you can actually set the Infinity to ignore incoming MIDI clock. Similar to above but done from the Infinity looper side.

    • Using the Infinity app, tell the looper exactly how many bars long the loop is. This can be done after a loop is uploaded or recorded. This way, the looper knows whats going on and does not try to correct/compensate for the incoming MIDI clock.
      In the Infinity application, enter the number of measures in loop 1 for the affected loops. There is a list on the left hand side displaying all the presets on the looper, whether they be filled or empty. When selecting a preset from the list, the user is able to change any of the given settings for that preset. The option to write in the measures is right below Split mode, between Arm Mode and MIDI Time Signature. If that does not solve the pitch issue, there are probably incoming MIDI notes to the Infinity (which can be disabled from either device) triggering the Varispeed function of the looper, which will cause the change in pitch.


Thanks Persist. Good stuff!

Great stuff…good to know 'cause I just bought the BB Pro and Pedal and haven’t had a chance to hook it up to my Piggy Infinity yet, but thank-you for the heads-up. :slight_smile:

Hi, I have had the pig looper for two years and still don,t know how to work it. I also just purchased the beatbuddy. I’m determined to learn. Wish me luck…

Good luck, but more importantly, have fun and don’t be afraid to explore what the looper and BB can do. :slight_smile:

1 Like

Hello Persist, having a hard time with the looper. Sure wish there was a dedicated forum regarding the infinity. I’m having mainly timing issues. I just want to make and save songs. I’m trying to do Daytripper, maybe that’s the problem. That song has a lot of parts…

Same here. Wish Pigtronix would host a forum so users could discuss how to make their loopers work better. Some users do share their feedback on TGP looper threads but it’s not a dedicated functional and technical users forum.

Thanks for the tip. I visited the site and became a member. Sounds like I’m not alone. I have faith in this looper!

It’s a good looper and can be used with your rig in a couple of different ways. The Pigtronix folks do their best to resolve issues that are brought to their attention.

1 Like

I had dramas when i first hooked them up - updated firmware on both and has been a dream since! Such a fantastic setup.

Hi everyone

Just joined forum. New to BB & Infinity Looper which I have had for a few weeks.
Been able to find my way round BB which seems to have much support.
Not so with Infinity Looper, in particular one issue maybe someone has come across.

It concerns running the Pigtronics setup program via USB which my particular set up (W10) is reluctant to do.

At first, I go the message NO LOOPER FOUND

I then discovered I had to run the program as administrator.

This worked after first going thru an initializing ceremony and I was able to access all the parameters. Great I thought… until later on in the day I tried again & it would not open after initialization.

I got in touch with Pigtronix support who, to be fair, were quick to respond. After running through a few things that didnt work I was told to format the SD card which was done internally. Much to my relief this worked and the program loaded! I thought issue was solved until some time later I tried to access the program again & I was back to square one…

Support at Pigtronix are a bit sick of me now as they are not responding. Before I send this unit back I am wondering if any IL users here may have any suggestions.

I have tried different leads, a W7 laptop, cleaning the SD card contacts to no avail.

Apart from the described issue, everything else seems to function as it should.


I seemed to have tracked down the problem to corrupted files on the SD card.
Reformatted card & downloaded new image from site.

Thanks Pigtronix. You were no help at all. I guess with most of this highish tech stuff we are all on our own…

Hi Vangelo (and anyone else who can help!) -
I have two issues with Infinity and Beatbuddy:

  1. I have a similar issue when I try to run the Pigtronix Infinity Application (on my Windows 10 PC). I run it as ‘Administrator’ whereupon it opens a window with some text starting with ‘Software Version 2.110000’ and ending with ‘Disk Format Version 5, Disk Format version not recognised’, and then a second window opens with the ‘No Looper Found’ message. I assume this may mean the SD card has corrupted files. Please can you explain in simple terms how you reformatted the card and then downloaded a new image from the site? (I find the Pigtronix website fairly confusing!).
  2. Before trying the Infinity Application, I had previously set up Infinity and Beatbuddy (plus B’buddy footswitch) together briefly, and initially all went well when in ‘Parallel Loops’ mode. However - with Infinity in ‘Series Loops’ mode, the B’buddy pause/unpause function did not stop/restart the Infinity. I assumed this might be due to outdated firmware, hence my foray into the Infinity Application…

Any help on the foregoing would be gratefully received. Thanks…

A couple of previous posts that might help a little:

And here’s how to reformat the SD card in hopefully a little more “Dick and Jane” terms. This will reformat the card to factory default.

  • Power up the Infinity while holding down the Series Loops button.
  • When you see a “r” on the seven segment display, let go of Series Loops.
  • You’ll see the display flash between ‘r’ and a number.
  • This number represents the number of presets to format the Infinity with (5= 50, 4= 40 etc).
  • You can change the number of presets with the preset encoder.
  • Once you’ve got the number you want, press down on the Preset Encoder and wait for the Infinity to reboot. It will have formatted itself with the correct number of presets to the factory default settings.

Bob…nightmare isnt it?

I tried all the internal reformatting which didnt work.

The guy in post #11 from this thread was a godsend:

I have to say now that I have got Infinity/Beatbuddy working together I am a bit bored. Studying the looper market I have invested in a Digitech Jamman Solo XT. Now, if you can figure out how to use the thing, a pair of Solo XTs synced with the new Digitech SDRUM should be a killer combination!

Thanks persist and Vangelo. I reformatted, reinstalled and updated everything, then tried to open Infinity Application with Infinity connected to my Windows 10 PC but the same ‘No Looper Found’ error message showed, so the App would not open. I then dug out my old Windows XP laptop and connected Infinity to it, opened the App and it loaded correctly. So for now I’m happy to use the XP laptop. But should the App work on Windows 10?

Since reformatting, etc., two new files .Trashes and .fseventd and one .-.Trashes file have been added to the Infinity drive, but I’ll leave them alone unless problems continue.

I haven’t yet connected the Infinity and Beatbuddy together, so I don’t know if the pause/unpause issue in Series loop mode has been resolved. I’ll post again when I’ve tried that.

I recall reading that Pigtronix might have been having problems with their app working on Windows 10 but I think the same applies to several 3d party apps not working or behaving as expected with Win 10.

I’ll try to test the Series loop pause/unpause but probably won’t get to that until early next week so I’d be interested in hearing how it goes for 'ya.

Bob…did you get the new image on the card using Win32Diskimager? Thats the only thing that finally worked for me after losing more hair :mad:. I also tried old XP & Win7 laptops before doing this but they would not work.

Of course, app needs to be opened as administrator, and on mine it worked on W10.

Its so frustrating that we need computer skills to get this stuff working:confused: