Having to double tap foot switch

Can you tell me why suddenly I have to double tap my foot switch to get it to pause or start??

Does it do this on the BBM Virtual Machine?

No, on my actual BB pedal and foot switch. I am trying it again right now

Which versions of the f/w and BBM are you using?

Is this for the BeatBuddy or the Mini? If you have to double-tap on the Mini to get it to respond to commands, then you are using a latching footswitch and you need a momentary one, you must switch.

If this is happening on the BeatBuddy, then your unit is configured to either momentary/latching and you have the opposite one, run the footswitch detector:

Step 1: Press ‘Drum Set’ knob and ‘Tempo’ knob both at the same time.

Step 2: Choose ‘Footswitch’ option (by pressing the ‘Tap’ button which is located above the ‘Tempo’ knob)

Step 3: Choose ‘Footswitch Detector’

Step 4: Follow instructions on screen

This should solve any footswitch issues you are experiencing. If it does not, please let me know.