HELP OPB when export MiDI get clipping. drop out on BASS

Hi desperate for help as far as I can see , done by the book.

Created 2 midi tracks in Logic X Pro, quantised , on play to check everything tight.

When I import into Beat Buddy manager, sections drop out on Bass notes. Have made sure
Bass is well clear of drums by transposing up +12 .
Using Rock with Bass.

Thank in advance for any pointers.

Andy Ray :sunglasses:

You need to change at least 2 things in the bass region for this to work:
Click on the bass region to select it

  • In the upper left corner, click the Region triangle to expand it
  • Notice where the bass says +12? You need to use the dropdown to change it to 0

  • Once it’s changed to 0, double-click the bass region to open the editor (or you can press the keyboard shortcut E), No idea why LPX handles bass notes this way—it just does. All I know is that if you don’t make that adjustment, it causes problems if you simply try to transpose the bass notes
  • Notice how all of the bass notes are so close together? This is what’s causing the drop-outs and clipped sound
  • Select all notes in the bass editor; toggle the Collapse Mode (orange tab with up and down triangles—this refreshes the bass region from E1 to E0)
  • With all of the bass notes still highlighted; hold-click any bass note to bring up a sub-menu
  • Select Trim Note to Remove Overlaps for Adjacent (or you can use the \ keyboard shortcut)
  • Press Shorten if this dialog box opens.
  • Take a look at the next screen shot and you’ll see that the bass notes should now have some separation
  • Transpose the notes while they’re sill selected by pressing shift-option up arrow twice to increase 2 octaves or press shift-option down arrow 3 times to lower 3 octaves. This is based on using the NP StdPBass 63-91 kit or one of Phil_Flood’s kits so you’ll have to adjust according to Guitar Stu’s kits
  • While you’re at it, you might as well change the velocity for the bass region so that it’s kind to your speakers and listeners’ ears
  • With the bass notes all still selected, press Functions > MIDI Transform > Velocity Limiter
  • Since the bass notes velocity is generally around 80, I like to lower all notes to around 33 but YMMV
  • Make the selections using the following screen shot as a guide

Thank you so much for your detailed guidance with excellent screen shots.

this is going to save so much time as was going round in a loop chasing my tail
trying to crack this. All makes sense.

Had started to manually trim overlaps and in sections worked and in others even no overlaps was not working.

So thank you again for all the wonderful detail you have provided.
So important for me as I 'am getting bass tracks to gather in Logic for recording my songs
to upload to my website and then to use in BeatBuddy for live performance, so this is
a real big help.

What a great Forum for a great musical instrument. Thank you.

Andy Ray :grinning:

:white_check_mark: :musical_note: :guitar: :drum: