Help with Reaper editing a song

Hi everyone, I’m new around here, my first post, so thanks in advance to everyone will be willing to help.

I downloaded one of the version of “Little Wing” from this forum, it’s an old one that goes with StandardPBass kit. I found the bass to be too… prominent in the mix, so I was attempting to fix that with Reaper, by lowering velocity on the bass part.

I read @persist guide, and I managed to lower velocity for the bass part on the prejam (intro) and postjam (outro) but I have a problem when I try to open in Reaper the “main” part (the one that goes in loop).

I get this:

If I try to open Reaper midi editor, it does open:

Anyway if I edit velocity on this file, export and then set the main part in BBM, I found that the part looping has two beats missing at the end of the loop (silent).
Not sure if I explained the problem clearly, I suspect this thing has somehow to do with the time signature but I have no idea how to fix it.

I know this is more of a “reaper problem” than a beatbuddy one, but since I see some folks in this forum using reaper I tried to give it a shot.

Thanks! Keep beatbudding.

PS the song is this one: Little Wing 2017-12-04 - Jimi Hendrix - re-upload by request

I’m not sure what you mean here: Is the part now (for example) 6 beats instead of 8? or is it 8 beats but 7 and 8 are silent? And if they’re silent, is it the whole track or just the bass?

The looped section appears to be in 4/4 when imported. So the last measure has sound only on the first two beats, the last two are fully silent (bass and drums). The loop is supposed to restart after the first two beats, the silence is not right (being the song at 60 bpm it’s a 2 seconds silence).
I tried to set 2/4 time signature in reaper and in BBM, but the pause is always there. Besides changing the time signature in BBM produces a strange effect on sound.

Ah, okay.

Reaper exports MIDI in increments of the set the time signature, filling the last bit with silence. You’re saying there is material in those last two beats, yes? There are a bunch of possible issues here. Have you tried to import the file back into Reaper to see what it looks like?

Couple of things to check in Reaper:

  • Make sure your file starts all the way to the left right up against 00:00:00 time.
  • Make sure there is a beat at 0 – the very first beat available – even if it is a silent beat
  • Make sure the section is a multiple of the measures indicated by the time signature – empty half-measures will be exported as empty.

I’ll try to keep an eye here, let us know how you’re getting on.

Thanks Joe, I’ll double check the things you suggested and let you know.

I made it work, finally.
The problem was indeed the time signature. The original (exported from BBM) is in 2/4.
What I did was set same time signature (and tempo) in reaper, BEFORE importing the file.
Than, I edited the velocity on the bass part and when exporting from reaper:
Ticking the option “Embed project tempo/time signature chenges” is what did the trick.

Thanks Joe for support.


There are so many ways to go wrong with MIDI in Reaper. I know. I was a Kickstarter buyer, and I’ve managed to hit ALL of them.


Congrats on solving your problem!

1 Like