How to end a drum fill/transition with a Cymbal crash to start the next song part

Probably free 'cuz I can’t get it for free googling everywhere. Have you a link to share ?

https://shop.presonus.com/products/studio-one-prods/Studio-One-3-Prime

https://www.presonus.com/products/studio-one/get-studio-one

I have a slight variation using any midi editor. It’s essentially the same. One of the greatest BB successes for me was the night I discovered that if I added a kick and hit on the first beat of the first measure after the fill, BB played it without a gap (by falsely thinking it needed to play the rest of a non existent measure). It just adds that first beat onto and over the top of the existing midi file you are transitioning into. It works every time.

When you do that, do you write a full mostly blank extra measure as part of the midi file, or is it just the fill plus the extra hit, such that the midi file for the fill would be, for example, just 4 beats + 1 hit long?

A complicated question right now actually. I’m not always modifying existing and sometimes that process can be funky in the editor we’ve been talking about, mostly because when I import fills to modify, add to other sections, etc. they don’t always show up in the editor as one might expect. Lots of times I just give up and write my own, especially if it’s something unique to a particular song–say a breakdown that goes on for 8 bars and then builds up back into the main groove, etc.

[FONT=Arial]I’m still not getting it. Assuming a one measure transition fill going into a four measure part B main loop, it normally looks like this:
[/FONT]
[FONT=Courier New]Transition Fill Part B Main Loop
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
[/FONT]
[FONT=Arial]Do you add the extra beat here:[/FONT]
[FONT=Courier New]
[FONT=Courier New]Transition Fill Part B Main Loop
1 2 3 4 1 1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
[/FONT][/FONT]
[FONT=Arial]Or here:[/FONT]

[FONT=Courier New][FONT=Courier New]Transition Fill Part B Main Loop
1 2 3 4 4 1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4[/FONT]
[/FONT]

Just create a transition in any midi editor and add in a kick and crash on the downbeat of the next measure (in the transition). It works for me.

Hi,

I have the same problem, do you found a solution ?

thanks

I am using BB midi editor and I use the technique whereby you create the fill or transition using however many measures you need, then add an extra measure with only the first beat triggered in that measure. “Apply” then, without touching that extra beat in the new measure, reset your measure count to the actual number of measures of the fill. Works every time!

Thank you for that clear explanation. I have an upcoming project where this will be absolutely necessary.

As a drummer I avoid a crash hit at the end of a fill particularly when the next part has vocals. Crash cymbals tend to drown out singers. The first word of most vocal lines is important. Punters like to hear the words.
I wrote a program to update all the BB fills to convert the end crash into a high hat hit.
I use these fills when the next part is under vocals.
Too much cymbals in the vocal space will have your sound guy eq’ing the drums so the cymbals sound like corn flakes.

This should be permanently documented on tips for creating fills. I searched several other topics discussing how to do this. One of the guys suggested just off setting the end beat to fit within the measure. While its ok, it’s not great. I apparently wasn’t using the right search terms when trying to find how to do this, but I accidentally found how to do this by comparing a beat from one of the existing files and was trying to import it into a new song and the fill kept playing the rest of the measure (which was empty). When I lowered the measure count the last note went away, but decided to try it anyway and it still played it.

Might be an old discussion but here’s my pennyworth: I found this out accidentally when I’d deleted a couple of measures and couldn’t understand why a sound I couldn’t see still played. I added the extra measures back and found the pattern still there so deleted everything in the first bar then reduced the measures back down again and it was fine. Likewise, creating a measure, adding your instrument sounds, then deleting the measure again will give you the instrument sounds at the beginning of the next measure.

Hi, its a bit of a late response, but i was having the same problem and changing the last bar to 16ths worked for me aswell.

I am relative new creating my own songs with beatbuddy and I have the same problem.

the problem is when you create your own patterns for your song you have 1 or 2 or n bars of notes and when you transition to an other part of the song or just a fill and come back to the same loop part of your pattern there is no accents that makes you feel there is a change happening.

I finally figure this out, you just need to add an extra bar of notes at the end of your intro/fill/transition pattern with the notes accents or drums or whatever you want at te beginning of your next part, if you play this your intro/transition/fill is going to sound one bar extra with the ending you want and then empty notes, for example imagine you have 2 bars with all the notes you need, but at the end you need a crash accent that need to play at the same time of your first drums from your main part, after adding extra bar you will have 3 bars but the las bar just has a crash at the first note, save the changes, then return to edit and reduce the number of bars without deleting any of the notes of the last bar that contains your accent.

is like you create a hidden bar at the end and it just merge with the beginning of your next part

Doing that your accent will play at the beginning of your main part at the end of the transition.

took me 5 days to figure this out, i didn’t see this anywhere.

I think it’s just something you discover by playing with BBM.