How to Get BeatBuddy, Voicelive 3, iPad (Lightning Port) and Set List Maker MIDI Up - Quickly!

In case somebody out there wants to set up their Voicelive 3/BeatBuddy/iPad/Set List Maker gear MIDI up and running (I’m just talking, at the moment, about getting the basic MIDI connections and timing up and running; not talking about more advanced parameters), you can try these setups (I’ve listed them in cascading menu/submenu order) to get a running start, though in the end, you may want to tweak your setups to get what you need. This is just to get you in the ball park:

(NOTE: I am using the iConnectivity ICMIDI01L 1-In/1-Out USB & Lightning iOS MIDI Interface, which you can find on the 'net for around $59). There are other ways to do it; for instance, using a “Camera Connection Kit”, etc. And there are other mfrs of MIDI interfaces for this science project. But I’m not going there, at the moment. Just going to go with the setup I’ve decided to use:
[INDENT]iPad Lightning Port to iConnect Lightning Cable
iConnect MIDI OUT (black) to BB MIDI In Cable
iConnect MIDI In (white) NC
BB small MIDI I/O Connector to side of BB

BB Settings:
[INDENT]Main Pedal
[INDENT]System Real Time
[INDENT]Disable (Prevents VL3 from handling Tempo)[/INDENT][/INDENT]
MIDI Channel Number
[INDENT]Output Type
[INDENT]Channel 1[/INDENT]

VL3 Settings:
MIDI Tempo
Input Channel
Output Channel
Input Filter
Output Filter
Also, when using BeatBuddy as your timing source, the VL3 Looper must be set up for either QUANTIZE or SMART and MET ON.[/INDENT]

Set List Maker Settings:
[INDENT](Select desired Layout to modify)
Play Automation Track
[INDENT]On (probably not important for this exercise)[/INDENT]
Play Tempo
[INDENT]Off (Lets the BeatBuddy handle Tempo)[/INDENT]

I’ve now tried this over and over…just can’t get the bb to respond. I’m wondering if my controller (a cheapo amazon controller) might be the culprit, but the correct light (output) does flicker, and SLM reports that data is being sent. I ordered a new, better controller that should be here tmrw. Might also be my connections… I have midi-out to BB IN (on bb mini midi cable). I wish there was a way to test the cable to see if data is actually getting all the way to the BB.

it should be easier than this.

Hey Phil; I think I have some good scoop for you.

I beat my head against the wall for a few hours when I first set up my iPad Mini/SLM/VL3/BB rig, until I discovered that my new BB MIDI interface cable was intermittent, on the path between the iPad and the BB. I’d be willing to bet that you’ve got the same sort of problem. It took a while as I jerked the cable around while testing until eventually I had the smoking gun. I notified Musician’s Friend, where I had bought the cable, and a few days later got a free replacement. It was an immediate fix. Hope this helps!

Interesting. So let me get this right… do you mean the cable that plugs into the BB (and then plugs into the controller etc)?

I am also thinking that my controller may not be IOS compatible. I found a tidbit on an apple forum re midi controllers, roughly 1/2 are not compliant. I have a new one coming tmrw.

Yes, it’s the “Y” cable from the left side of the BB’s miniature MIDI port, with standard sized MIDI connectors on each end. If the new part you ordered isn’t the fix, then look very condescendingly at that “Y” cable!

Absolutely and thanks for the heads up. I really hate having to replace things one at a time, but that’s how it goes. It’s a real shame that the pedal can’t report on whether it’s connected to a midi I/o.

Hey… wanted to let you know… it was the midi controller. As Apple Support said, it needs to be an Apple IOS , USB Compliant approved controller. The iConnect arrived this morning. Hooked it up. Everything is working!

Now I have to deal with 700 songs!

Awesome. The iConnect Lightning is the same one I use. Glad to know you got it to go.

I just noticed that you let bb handle the tempo. I can get SLM to export the beat clock of its tempo field to the bb correctly, but if the next SLM song doesn’t have that field filled, the bb retains the last tempo rather than resetting to default tempo. Any ideas??

Yeah, that, and a few other annoying things, made me decide to let the BB handle tempo. I can’t remember exactly what the other reasons were though. But for my uses, I decided to leave SLM out of the timing picture.

I might have a fix, or at least a workaround… experimenting today.

Can you plz let me know what you come up with?


k… so this is what I know… excuse the length of this…
First, here’s the issue. If the beat clock if the bb is set through SLM (appropriate fields set etc etc), IF the next song in a show doesn’t have a tempo in the tempo field, the beat clearly cknstays at the previously sent value, rather than resetting to whatever you have the bb’s song tempo.
Example… in a show, song 1 has tempo field at 199,song 2 doesn’t have the field field, but has a BB setting if 120. If Song 1 is selected, bb clock is set to 199. If then song 2 is selected, which should be 120, bb stays at 199.
IF we had song durations, or a three or four button Bluetooth page turner (which I might get), there are easier solutions. Example, Bluetooth button 3, could be latched to “select next song and turn off tempo”… but, it’s more buttons on the floor which is what we’re trying to avoid…

SOLUTION… I noticed in the SONG list on SLM, that the clock could be turned on/off by tapping the metronome symbol. So, I tried the same in the first two standard layouts.

  1. set up your show, in a song or two, remove the tempo (for testing)
  2. start the show, select BIG SET LIST and note the symbols. You’ll see the Do , midi and tempo symbols.
  3. pick a song WITH tempo… clock should start, bb responds accordingly
  4. now switch to the song without tempo and note that the tempo doesn’t change, right?
  5. go back to any song with tempo… bb should respond… NOW HERE’S THE SOLUTION… BEFIRE SWITCHING TO THE SONG WITHYT THE TEMPO SETTING, just tap the metronome symbol of the current song, turning OFF the metronome.
  6. now when you switch to a non-metronome tune, the bb keeps the tune’s correct setting.
  7. YES, it’s an extra step, but it allows you to use the bb tempo knob. If the beat clock is set through SLM, the tempo knob doesn’t work.

I’m working on a more elegant solution using midi CC commands but waiting for a response from Arlo from SLM.

I have only skimmed your latest post at this point, but in skimming it, I noticed the last bit, “7) YES, it’s an extra step, but it allows you to use the bb tempo knob. If the beat clock is set through SLM, the tempo knob doesn’t work.”

I think that’s why I opted out of letting SLM do it. See, I play solo gigs, with either backing tracks, the VL3’s looper, BB+looper, or BB drums only, or, in many cases, nothing at all backing me up. Depends on the song I am playing. Since getting more familiar with the BB, I’ve been experimenting with what I guess could be called “solo jams”. So in addition to the usual setlist, I have set up SLM, VL3 and BB for 3 different “Jams”, whereby I can just free-wheel it, looping 2 and 3 chord bass/rhythm guitar/drum patterns. Sort of like a “jam session with myself”, if that makes any sense. Examples of songs where this works: Goin’ Down, or Stand By Me, etc. Not really doing it comfortably yet, but I’m working on it.

To do this, I set up the BB with 3 Jam Folders, in addition to the other .sng files. A half-dozen Blues beats live in one folder, a half-dozen Rock beats in a second folder, and a half-dozen Funk beats in a third folder. In the future, if this approach works out, I will add other folders with more genres. On my VL3, I also set up 3 different “Jam” settings, each with 4 Steps. Step 1 is Bass (set up the VL3 Octaver to make my guitar one octave low), Step 2 is Rhythm Guitar, Step 3 is Lead Guitar, and Step 4 is any other types of effects (for example, in the Funk setup, Step 4 is AutoWah. This way, I can pull up the first .sng file in each BB folder, which is tied to its corresponding VL3 preset, thanks to SLM. Since I renamed the .sng files with easier-to-understand names, and limited my choices to 6 files, I can scroll through them quickly via the BB’s outboard pedal. Then I just change the tempo to my liking, and off I go.

So, to summarize, I select a “Jam” via SLM, and up comes a 4-step VL3 preset, and a corresponding BB folder with its six jam beats, waiting for a possible tempo change. And BTW, I admit I am lazy and do use bluetooth page-turners, as well as an iPod on my mic stand, linked to my pedalboard-mounted iPad via a little wireless LAN stick which is also on my board. That way, I can go through songs serially via page-turner pedal, or skip around using the iPod, as it relays the song selection to the iPad. I know, it’s probably needlessly complex, but then again, I really love doing it this way, and frankly, I only had to engineer the whole thing once. Makes my rig super-versatile, saves my back, and looks more professional than stooping all the time.

Anyway, long story, but if I remember right, that’s the main reason I let the BB do all of the tempo setting. Though I’m pretty sure I had other reasons.

Here is a practical question: using a Yamaha MD-BT01, will the device work (communicating with an iPad) if the “IN” is plugged in the “IN” of BeatBuddy, and The “OUT” plugged in the “OUT” of Voicelive 3x (which should power the device) , theBeatBuddy “OUT” being connected to the Voicelive “IN” ? Any thoughts welcome…:wink:
To put it simply: does the Yamaha MD-BT01(the “IN” and “OUT”) has to be plugged in the same pedal/instrument?
PS: I wonder if I should buy the Yamaha MD-BT01 to be able to control both units (VoiceLive and BB) through Onsong on my iPad mini.

Well, I got an answer:

Hope this is OK to post here. I’m also having trouble getting BB to respond to song change using BandHelper (SLM newer version, sort of). I also have SLM but i can’t get that to work either. After reading through this thread, I bought the iConnectiMIDI1 cable. This works fine with my keyboard - MIDI in and out. Just to make sure the BB MIDI breakout cable wasn’t the problem, I bought another one, but still no luck.

I’d really appreciate it if I could ask how you’ve gotten this setup to work:

iPad running BandHelper > iConnectMIDI1 > BB
I set up a MIDI preset on BandHelper as follows:
0 | 0 | 0

That should call up the first song in the first folder, right? (I have 3 folders on the BB.) Or am I doing this wrong?

Thank in advance for your help!

I’m running the latest firmware - 2.0.4 and for what it’s worth, BandHelper’s MIDI Status Activity log shows
sending data to all ports


*I also fired up SLM and got the same results - sending data…but no response from BB.

Thanks again.