How to get the BB to stop 100% when the pedal is double tapped

Hi y’all. I bought the BB for my trio to use, I have the intro and outro turned off through Main Settings. We used it for the first time at a gig this past weekend.

** How can we get the BB to stop when I hit the pedal for it to stop. We don’t want the extra beats to finish out the measure.

I do not use the footswitch.

Please help?!!

You really need the foot switch setting button 1 up to pause stops the beat instantly. I also play bass in a trio and operate the BeatBuddy I use the midi maestro but the principle is the same.

I do have the footswitch but I have not used it yet. So if I pause, do I choose the next song and then that will solve this issue?

If you pause using the footswitch, it’s an instant “pause” (not an immediate “song stop”). Choosing the next song will “clear” the current song and move to the next one without making any sound.

You can just hit the other foot switch button which if set to stop BB after you pause there is no sound.

I set my floor switch to:

Button 1 BB stopped Advance tune forwards
BB running pause song

Button 2 BB stopped advance backwards
BB running stop song at end of measure, outro fill if selected.

1 Like

In the settings menu you can disable the Outro, then you can use whichever switch you want to pause or end the song without the extra flourish on the drums


Have you checked the settings. You can setup triple tap to immediately stop the song. Hope that helps solve what you are looking for…

Also if you have the BeatBuddy Manager (BBM), you can remove the outro and save the files so when you double tap, it will end the song without an outro, this will however continue to play to the end of the bar.

Can you briefly tell me now you turned off Outro? Do I need the extra foot switch?

You could add a “null” outro…or what if you made an outro with a quiet foot hat on 1 and 4? So when you trigger the outro it plays but isn’t really audible.

Different ways to get to this end.
Assuming you are on the latest Beatbuddy firmware.
For disabling outtro. In your beatbuddy, go to settings (press drum and tempo knobs) scroll to main pedal, and then press tempo knob.
Next scroll to outtro and then press the tempo knob.
Now choose the disable option. This will cause the outtro to not play when you double-tap the main pedal. But remember that the currently playing bar will continue to play to the end of the bar.
This is a global setting for all songs.

The suggestion from josborn777 is also an option to look into, as that is something you can configure per song.