Infinity looper with Beatbuddy question

Hi guys. I’ve been enjoying my Beatbuddy with the infinity looper for about 6 or 7 months now, but there’s one thing that bothers me; if I pause the BB (which pauses the looper also) and restart the BB with the main pedal to get a fill, the looper starts immediately instead of waiting untill the fill ends (like it does at the beginning of the song. Is there a way around this? Thank you

I have the 45000 Looper and it does the same thing, so not sure.

Resuming the song from the BB’s main pedal plays a “fill” instead of the intro, so somehow the looper knows the difference between the two.

Unfortunately, no workaround at the present time.

In the future possibly?

Not sure about a future possibility. A workaround is to use OPB songs but that may not quite be what you’re looking for.

OPB? Not familiar


One-press bass songs

Just bringing this topic back to life. Any possibility that starting back from a pause with a fill, works as when you start the beat with the main pedal? So that the Looper starts playing until the end of the fill?

Thanks a lot!

Hi! i didn’t know you had posted on here, I thought this was dead!

I don’t know why the looper starts playing at the end of the intro, but not the end of the fill that follows restarting from pause. I’ve gotten around this by disabling the “auto start” function of the looper. Not a big deal to manually start since the Infinity starts/stops at the beginning/end of the measure. so you can click it off anytime in the middle of the measure and it will start/stop magically when it’s supposed to. Unless it’s a REALLY fast tempo, then you gotta be on it.

The people at Pigtronix are great to work with. I’ll give them another call and see if they’ve come up with anything (they’re pretty clever).

Why am I having so much trouble starting the pig recording on beat one ? Everytime I try to start recording on beat one the pig will wait a whole bar before recording and if I am early it will record out of pitch and out of sync.
Is there some setting I have missed ? As far as I know I

A couple thoughts: have you installed the latest firmware in the pig (2.11 I believe)? Are you playing a beat that is something other than 4/4 time? I know that’s a strange question, but for a while I had to record a loop in 4/4 first, then it would sinc to any other time signature. I haven’t had that issue lately. If you are playing say, 6/8 time, you might try using the manager software and assign some presets to the time Sig you want. That should cure it.
Are you considering the"first beat" the first beat after the intro? If you’re not using an intro beat you will never get the pig to record in that measure because you have to press record anytime before the top of the beat. Same with ending the loop. I find that tremendously helpful because I can be really sloppy with my pedal press timing and the pig will record perfectly.
One other idiosyncrasy I get occasionally is when I change to a beat that has a dramatic change in tempo: Gotta give it a minute to sync up.

The issue I wrote about earlier (not wanting the pig to play my recorded loop until after the secondary intro (pressing the main pedal after pausing) had finished, has been accomplished with the latest BB firmware installed. You might look into that while you’re at it.

One last suggestion; double check the midi cords for a good connsection and plugged into the right jack.

Good luck my friend, if i think of anything else I will pass it along, and let me know if any of this is helpful or if you have other questions.

Thanks for the reply , I will look into it , only software not up to date would be the BB.
It was just the POP no# 1 first drum pattern , but as far as I know its all pattererns and timings.