Installing new beats trouble

I tried installing the “Hand drum beats minipack” to my SD card using the instruction video above. When I got to the “Synchronization” part things went haywire. On my mac workstation I can see that the beats are on the SD card but when I plug the card into the beatbuddy they are not there.

Make sure your SD card is not locked and try again.

The card is not locked I am attempting full disaster recovery at this point. I am using the attached instructions. WHen I get to step 9 there is nothing reading on the beatbuddy display that allows me to “set footswitch and pedal settings”. There are no “songs” present at that point. The pedal reads
Time sig. -/-

Vol 38% 110bpm

Strange to hear that step 9 is not displaying the foot switch menu. If you are pressing both the Drum Set and Tempo buttons at the same time and it does not display the Settings menu it could be an indicator that the firmware might have been messed up somewhere along the line. Before you try to reinstall, power the pedal down and check again, making sure that your remote foot switch is firmly plugged in with a TRS patch cable. Still no Settings menu when pressing the Drum Set and Tempo buttons? Download and reinstall the firmware.

If you’re still not seeing the songs, follow the steps here: SOLUTION: “NO SONG” (error message)

If still not working, please contact Support. Their e-mail is in the link instructions.


When you say you see the songs on the SD card but not on the BeatBuddy, do you mean you are looking at and/or editing the actual files on the SD card? Everything must be done via the BBManager, not with drag and drop directly onto the SD card.

The NO SONG error message is typically caused when a user modifies the files on an SD card and accidentally gets rid of files that shouldn’t have been deleted. (there are some other causes as well but that is the main one)

In your BBManager do you see all your other genres as well? Blues, rock, jazz, etc? Or just the minipack by itself?

What version of Mac are you using?

OK I finally got the content on the card. The instructions in my observation do not mention copying the content on to the card, only the firmware installation. I must not be accessing the right support site or manual.

I was trying to get the bonus hand percussion on the card but noted when I installed the latest downloadable content they were included.

I was looking for how to install the content on the card as well a short while ago as it had been a while since I did it and I wasn’t sure I was doing it correctly. There was a link somewhere and I don’t recall where, that presumably was to a video to install content, but it took me to the same video you got probably for the firmware install.
This I believe is the correct video…

Ultimately I did use the “drag & drop” method. I believe my problem was at the step of synchronizing the content.

@Honeycombkid Has everything worked out? If not, send me an email to and we will arrange a phone support session.