iPhone 6SE Midi Command Issue

I’m having an issue with my iPhone 6se sending midi. Beatbuddy instantly loads the tempo, but only occasionally will it send the program/song change. Everytime I switch songs, the tempo changes, but not the song/program.The midi program commands are correct. When touching the “Test Command” prompt it works. But, that is the only time it will send the midi command. The iPhone is running iOS 10.2.1…Onsong is 1.99992…Hopefully a solution will come soon…My iPad works flawlessly. I pulled out my retired iPhone 5 and downloaded Onsong, and it works flawlessly. They are also running iOS 10.2.1…

Fix’s tried:
Restarting/resetting all items…multiple times
Deleting all files and reinstalling them
Deleting and reinstalling Onsong…again, multiple times
I tried all Onsong debugging tools
Sent an email to Onsong…still waiting for a reply
I found others with same issue, but no solutions

Almost sounds like the iP6se (especially since your iP5 with the same iOS seems to work fine) has a problem passing the midi commands. It would be nice to step thru each midi command separately to sort out the issue.

I’m also pretty sure it’s my new iPhone…I’m sure it’s not the Beatbuddy…I spent the evening searching for solutions but with no avail. I find it odd that the tempo always changes, but not the program. I checked each midi setting (multiple times) and they are identical to my iPad and older iPhone.

One thing I didn’t mention is I’m using the Yamaha MD-BT01. I don’t have, nor do I want to have a wired cable connection.

Is there any way to put like a 200ms delay between each midi command?

This is what I’m thinking you could try: http://onsongapp.com/docs/interface/menubar/utilities-menu/editors/midi/editor/delay/

If it doesn’t work at 200ms, increase to 300ms. If this works, next step is to reduce delay by 100ms until you find a delay amount that works. Good luck.

This seems to be the issue, but not the solution. It’s up to 700ms and is working sporadically. It’s better than not working at all, but not good enough to be reliable in a live situation. I don’t think I want to go higher than 700ms

Well it seems like 900ms works consistently, but what a distraction and bother to make it work for one iPhone…thanks so much for the quick responses!!!

Again, thanks for the very quick responses!!!

At least it gives you an indicator of what the problem might be. Sometimes when I have issues with my iPhone 6 powering it off and then back on seems to settle it down (yes, even after a restart following an iOS update). Maybe turning Bluetooth off and then on, too. Jason should be able to provide some additional things to try.

I may just use my old iPhone for onstage performing, until there is a better solution.
I have a few reasons for wanting Onsong on my iPhone…
[]To take up less space on stage, since I just use it for set lists and sending midi to the Beatbuddy (a quick swipe and onto the next song)
]Having a backup
[*]Plus, I always have the phone with me
I have been having a ball, since getting the Beatbuddy! It’s a fantastic tool for live performances, writing and practicing. It has helped make me a better player.

Okay, for anyone else having this issue, I found the easy quick fix!!! Now my iPhone 6SE works great with ONSONG!
Add your MIDI delay time here.
After a little bit of experimentation, 1 second is the time that works best.
The solution Persist posted works per each song, but this is a global setting fix.
Thanks for getting me on the correct path to a solution, Persist! I’m new to working with MIDI and ONSONG.