Issue with Press and Release commands

My Maestro is running v1.1.7 and I have the latest version of the programming app running on an iPad (8th Gen) running OS 15.2.1.
I have created a custom mode from scratch that is required to send different MIDI commands when pressing and releasing the buttons. I also use the toggle feature to send different commands in the 2 toggle states. The toggle feature appears to work fine, but the press and release feature appears to be badly broken. I am finding that some commands always seem to be sent on the release action, regardless of how I program them, and others are always being sent on the press action. I have monitored my MIDI connection and confirmed this to be the case. I even tried designing a specific test mode to verify my findings in case it was a feature of the custom mode that I had created and the behavior in the two different modes was identical. I have previously used this feature for switching beatbuddy drum patterns and it worked ok, so I am somewhat mystified as to why it has suddenly stopped working. Any suggestions? Did something change in the latest MM firmware?

Here’s a little more information on this issue. I have confirmed that the Midi Maestro programming app is correctly programming the Beatbuddy song part CC-113 to start part transitions on the press and complete the transition on release. However, I have defined 4 custom commands: “Track 1 Start”, “Track 1 Stop”, “Track 2 Start” and “Track 2 Stop”. My application requires me to send the Start commands on a button press, and the stop commands on a button release in order to achieve a transition from playing track 1 to track 2, and vice versa. The problem that I am having is that, regardless of which buttons I use to program this action, the Track 1 Start command is always being triggered on a button release, and the other three commands are ALL being triggered on a button press. I’ve tried programming different CC values, different settings values, and reversing the press and release conditions, all to no avail. Since I’ve tried moving the commands around to different buttons of the Maestro, which I know work fine with the Beatbuddy song part commands, I have to conclude that the issue is in the IOS app. Has anyone out there had any success in programming custom modes with different press and release actions? I am at a loss to explain what could be happening.

What do you want?
Switch from part 1 to part 2 with a transition, and change the part on the beatbuddy to or not?
Please resume what you want

Nothing to do with Beatbuddy.


Toggle state switches back to track 1. Simple!

I am reporting a bug in the singular sound app that is not correctly applying the press and release conditions. A meaningful response from Brennan Jasso, or colleague from SS would be appreciated, thanks.

You didn’t mentioned that you are using a Boss RC looper.
but what I can see on your pic is that you have not put the command correctly to proceed your task
The start track 2 on press is good
But the other command need to be in the “SECONDARY FUNCTION”
This mean UNDER the toggle click on the + and add your second command as release
Don’t forget to save

Wouldn’t matter if I was trying to turn on and off light bulbs. The problem is in the sending of different commands on push and release. Your solution is incorrect, but thank you for playing.

I wonder if this issue has something to do with the lack of a delete option for commands added under the “My Commands” menu option resulting in some sort of naming conflict. I tried transferring the problem commands across to my iPhone with a clean installation of the programming app, uncluttered by existing commands, and hey presto they work as intended according to the assigned press and release actions. I have also been able to define new commands on my iPhone that work correctly when I transfer them back to the iPad, even though I cannot get the original commands to behave on the iPad. It is a mystery indeed, although I do not plan to spend any more time on it as the iPhone trick allowed me to set up the modes that I was trying to achieve. It doesn’t appear that anyone else has seen the problem so perhaps something unique to my environment.

In any case if you activate the toggle button, you must add a command in Secondary otherwise it is useless what you are doing
Maybe you can try
Start 1 and Stop 2 on Press in Main function
Start 2 and Stop 1 on Release in Secondary function with the toggle ON

I do appreciate your attempts to help me, but I’m not actually having a problem in programming the 2 different toggle states of the button. I do have them programmed to perform different actions which, as you rightly point out, is necessary for things to work at all. My issue was that commands that I assigned to a release action were actually occurring on the press action and vice versa. As described above I have not been able to figure out why this was happening, but with the aid of a second iOS device, I have managed to achieve the outcome I was after. I have advised SS Support of my findings.