Latest firmware update - plus massive issues with my pedal

My Beat Buddy and the Footswitch that I bought earlier this year, starting having massive issues, it would get stuck in a transition, the pedal stopped working etc…under warranty (only 2 months old!) and they sent me a whole new set up. Its now doing the same glitches as before. I used it around 5 hours a week rehearsal and 2-3 gigs per month. I thought this time maybe the firmware update would fix it, but they have changed how the pedal can be set up. I’m lost and need help on this new way as I’m trying to double check that the firmware is in fact now set up this way, or is it just added non working features of a 2 month old replacement pedal. Here is what I want.

Left side switch play/pause. When I want a clean break, break on the 1 step back on the 1 and its back into the beat. Or for a cold hard stop ending. Is this no longer an option?

Right side switch as the main pedal. Intro//outro and fills. Although it won’t set like that.

Looks like it may not do main pedal on the right anymore? Which sucks I use a sustain pedal on my right foot and crossing my left over to the far side of the pedal for fills is obnoxious.
But regardless of the new firmware, it sticks in transitions won’t stop and works like shit and will not work for my gig tomorrow which I have built a whole show around. Needless to say, I’m looking for help, but feel pretty screwed right now.

I am a keyboard player and keep it up on a stand next to my right with a longer TRS cable to the footswitch below. I have emailed support but won’t hear back until tomorrow I’m sure.


I would put the older firmware back so you at least have the setup you want, I don’t know about the other issues

Hey there,

What version are you having this issue with?

The settings have changed in many ways in 4.1.x, please wait for support to get back

You are free to read the changes here

If the main pedal is set to react on the press, the BeatBuddy cannot be set to have a hold behavior and so cannot be set to stop with a hold when using the main pedal, you must set it to tap to stop in the Paused settings.

We split the While Playing and While Paused settings for more versatility as well

Simply go to the settings and configure as makes most sense to you with the new settings available.

If you set an Ext Footswitch to play the outro while paused and set the External Unpause (Main Pedal> Unpause behavior > External Unpause) setting to Stop Song, the footswitch can be used to stop the song immediately with one tap while paused.

We apologize if these changes caused issues for you but it is always good to do research on an update before updating and playing with it live

Thanks for the report

1 Like

Thank you for your reply!

I did hear from support who agreed that it should not say “latching”when it detects the foot switch. Suggested a new cable twice when I already said it was the first thing I tried, 3 different TRS cables. I reread the entire manual again which was not completely updated to 4.1. Regardless I’ve been gigging and set up a whole show around it. But right now I can’t get either switch to act as the Main Pedal. When setting the switch on the main pedal… it won’t give to option to enable main pedal. It’s just blank… perhaps because it thinks the pedal is latching?

I have reinstalled version 3.9.9. It didn’t help. All of the above still happens.

How I was using it when it worked.

1 switch to just be the main pedal.

And 1 that starts and stops … such as a cold break in a song. Press it stops, 4 counts, press again and it starts on the 1. Or the instant stop on a cold stop ending.

I will dig into your directions should I go back to 4.1. Thank you.

I didn’t receive notice or I missed notice that there was an update. However, I would never change or update before a gig without time to adjust. But the foot switch is not working. And the unit gets stuck in transitions. So I am just trying to do what I can for my gig tonight. Feeling pretty frustrated right now.

Thank you so much!

1 Like

Yup see below. Thats what I did. Still has all the same issues. It’s got to be cuz the foot switch thinks it’s latching when it shouldn’t be. Thank you for your reply suggestion very much though.

I just tried the firmware and when I ran the foot switch detector for the first time, it displayed “Latching” so I ran the detector a second time and it showed “Momentary”; all other functions now seem to be working properly.

I unplugged and replugged the power off and on, plugged the foot switch in and out at least 25 times since last night when my Beat Buddy apocalypse happened. It always says latching. But thank you for trying! I am going to my gig tonight with the pedal on the floor, which sucks to bend over to get the next song set up, but I’ll do a lot of my gig with just me and keys tonight so I don’t have to. In my gear graveyard I found a 15 year old sustain pedal from yamaha keyboard that actually shows up as momentary and will set to pause/unpause that will help with at least the gig tonight. Wish me luck!

Since I didn’t see it mentioned in your reply to me, did you run the foot switch detector immediately after the first one displayed “Latching”?

Anyway, hope you have a good gig and good luck. Hope you’ll let us know what it takes to get everything working with your BeatBuddy (BB) system!

Yes I did over and over. Still latching.

At some point in time the BeatBuddy footswitch had once been of a latching type and later was changed to momentary. Is there a highly unlikely remote chance you might have an older one that is latching? Did the ‘whole new setup’ that Singular sent include the footswitch or just the BeatBuddy?

You mentioned the Yamaha sustain pedal that works. If you have a sustain pedal input on your keyboard, try the Yamaha pedal and see if that sustains correctly and then try the BB footswitch and see if it also sustains when depressed and releases when the switch is let go (only one switch on the footswitch will do this). The TRS cable should work OK to do this (i think), but a TS cable could be tried as well.

My first BB and FS was in April, by June both were having bad issues they sent me a new BB and FS in June. Less than 2 months now and its all the same issues again. I assume it was the newer FS, and it used to say momentary, but now only latching.

I got through my gig last night using it less and letting it just run a beat and not do any fills or anything, On occasion I would press it for a fill out of habit and it would get stuck in transition mode and I’d keep pressing until it would eventually come out of it or I stop and start it, all this while still singing, playing keys on my right and a left hand keybass. I am looking at the Alesis SR18 setup. Maybe Beat Buddy is better for a home musician or for practicing and recording demos. I need a live on stage reliable piece of gear. That said I’m into this $500 and support did say he might send me a new footswitch maybe third time will be the charm.

Hey there Hollie … Tried something with my BB with the ‘Footswitch Detector’ function. When it came up ‘Press and Release Footswitch #1’, I mashed both buttons at the same time (Boss FS-5u’s). This resulted in the BB showing ‘Pedal Type: Latching’. This also hosed up the settings I had with the momentary button settings and the footswitches did not do what they were supposed to do as originally set. Switch #1 was originally enabled for ‘Main Pedal’, but became disabled in the ‘Latched’ setting.
Not sure if this is at all relevant unless you are accidentally mashing both switches when doing the switch detection or holding Sw#1 down while then pressing Sw#2 which also gives a ‘latch’ switch type. The detector works OK so long as I press and release Sw#1 and then press and release Sw#2 when prompted.

I do have an Alesis SR16 and it’s OK. The BB replaced it. I had thought about the SR18, but not sure it would have been any better than the SR16.

1 Like

I was doing 1 at a time, but it was also stuck and would never respond that I had already mashed #1. Thats good feedback though and thank you!. It’s maddening.

I had an original SR16 and and MMT-8 sequencer in the 80’s!

Just so you can see I’m not crazy here are 2 videos showing the crazy issues I’m having. Support is treating me well though and we are working on a solution.

LATCHING instead of Momentary has now become NO PEDAL DETECTED

I’m guessing you left the firmware at 3.9.9 as the foot detector menu is different than 4.1.0 and it refers to left and right rather than #1 and #2(?) If you try a ‘Restore Default Settings’ in the ‘Settings’ menu I wonder if that would get you back to where things worked the way they were intended and give a fresh starting point?
Yup, I still have an old relic MMT-8!

I did update to 4.1 to see if it would fix the issues, but it didn’t help, so I reverted back just to see if THAT helped. Restore default settings does nothing. Meaning it doesn’t restore anything. I believe I am getting a replacement. Its so clearly broke there is no fix for this. Thank you so much for your time and comments.

Do you have a simple ohm meter, so you can measure if the switches actually work or if the cable is broken? The problem might not be in the BB but in the switches or the cable, they might have a faulty batch of switches in a series of footswitches.

I had also thought the switches or cable might be the problem, but the 1st video of the BB not working correctly without the footswitches connected seemed point to an issue with the pedal itself.
Was kinda wondering if the firmware got corrupted somehow to the SD card or during the install(?)

Well the company is going to send me a new foot switch after I send the old one back. And maybe they did get a bad batch of faulty foot switches. But support as well as myself are blown away that I had the same issue on two different pedals where it gets stuck in transition. And I did try several cables and I don’t have a meter to check.

Thanks guys!

I was wondering if there was some type of corruption with the SD card but when I had these issues before on the first pedal I even uninstalled and reinstalled beat buddy manager just to make sure there wasn’t anything getting sent from my computer that can mess it upm. it’s just quite a mystery!