Logic pro to midi to BB

I’m playing a midi file on my logic daw plugged into my Beatbuddy with the appropriate midi cable, but there is no sound coming out. What am I missing?

The BB midi settings have to be set to receive midi notes in on the channel that you are sending from Logic. Then, of course, the BB has to be plugged into an amp, or you have to have your headphones on to hear what the BB is putting out. If you are using the BB and trying to record it into Logic, you have to have the BB set up as an external midi instrument within Logic, to route the midi, and you would then need to have the audio from the BB going back into your interface, to have Logic record that on a separate armed audio track. That the basic issue.

The midi file your are playing in Logic also have to have notes that match the mapping of the kit in the BB. That is, if your drums in logic and playing stuff up around C3, there is nothing that the BB will “hear.” BB kits are mapped to general midi, for the most part, which mean that most of the drum sounds are between C1 and B2. An exception is the shaker is mapped at B4.

1 Like

Midi set to omni. Headphones in set to 50%. Midi file in logic designed for Superbass G with drums and bass in appropriate midi range. BB pedal settings as follows;Screenshot 2020-12-04 at 17.05.09

still no sound

Enable note on and note off. That’s on the Midi In settings on the BB. You have to enable it to receive midi note data.

Yes make sure you enable it on the MIDI IN settings, not the MIDI out, let me know if you need more assistance!

Thank you gentlemen. My BB is now fully functioning. I attach a copy of my Beatbuddy settings in case someone might find them useful.

Beatbuddymidisettings.docx.zip (14.6 KB) Beatbuddymidisettings.docx.zip (14.6 KB)