Loop playback volume

Is there a way to set the volume level (relative to the input signal) of the loop playback (e.g. set the loop playback volume to be -3db compared to the input signal)?
This would be useful as most of the time we want the loops to be relatively quieter compared to our own playing.
While this is doable via many other ways, e.g. using the mixer to retrospectively lower the loop playback volume, or simply adjust your input signal volume using your guitar onboard volume control etc, the ability to set a default volume level for loop playback would simplify the process and make it much easier and quicker to build up loops.


Completely agree and been watching this forum for a year since I purchased Aeros. Tried EVERYTHING and recorded loop is ALWAYS louder. PIA to have to long hold left button every time to turn down the last recorded loop in the Mixer.

Thanks for asking again andyshieh… somebody please tell us there’s a buried function that lets us set default loop master recording volume. THX

1 Like

Why not just use the scroll wheel and proactively cut the master volume to the desired level? This can be done before you start looping.

1 Like

Thanks @Ranban624. Good to know there are people craving for the same feature!

@JusDandy - thanks. That is indeed a workaround, but not an ideal solution. Holding the switch to get to the mixer menu & carefully scrolling the wheel to get to a consistent playback volume every time just isn’t streamlined enough when we are looping song after song during fast pace gig. For something repetitive like this (99% of the time we just want all playback to be at the same relatively quieter level compared to the in signal) it makes sense to have a global setting that sticks around instead of requiring a repetitive action.

I use the Peak level to adjust my input just a little bit yellow color
And the master is not more than the Big WHITE line (on top)
And most of time I’m good
But the best way is to put a volume pedal just before the looper input , so you can adjust the input on the fly

1 Like

@NYHC I agree. I make sure my input is good like you mentioned and usually have no problem with the sound matching. I also use a TC Electronic Spark boost to solo after I’ve built my loop. If by chance, the playback volume is a bit too loud I just nudge the scroll wheel down a bit on the fly. It only affects playback volume not live input.

Thank you @NYHC and @JusDandy for your suggestions. These are all valid workarounds that I currently use as well and they certainly get me by.
Still, it would be good to see a playback volume setting coming to Aeros as that saves some unnecessary troubles especially when we want to minimize the time and complexity when setting up a busy loop. I’m hoping this is a relatively “simple” feature to realize but would love to hear what the Aeros team says.

Hi All… I’m just getting back to scanning his thread and I’m worked up all over again!.. this is a $600 state of the art looping unit and we’re using workaround terms like - “scroll the wheel proactively”, “hold the switch”, “volume pedal just before looper”, “nudge the scroll wheel”… where’s our standards!?

Something’s definitely wrong with some of our units for so many users saying they don’t have this issue yet I see a bunch others running in to this volume issue.

I’m running mono in/mono out and have tried both line and instrument level in and out yet this increased playback volume persists and instead of being spontaneous, fast and creative mid-song and laying down layers… I have to focus on an extra step EVERY time to tweak the levels down before I can continue… total inspiration buzz-kill!! SS please take note and add a volume default set feature!