Loop Start Time Delay Problem - BeatBuddy with Infinity

Hoping someone has some answers for me. I have the Beatbuddy with latest firmware and the Infinity looper with latest firmware. For some reason, the Infinity DELAYS the start of a loop when the Beatbuddy is running. You see a red rapidly flashing light for a few seconds before recording of the loop commences. Then when you play the loop back, there is a GAP in the loop. It’s like it is triggering some sort of delayed start feature that I don’t want. When the BB is disconnected, the Infinity is fine and the recording of a loop starts the moment you hit the footswitch, so I am confident it is a Beatbuddy problem.
The latest BB firmware update seems to have improved this problem. It still happens, but I seem to get lucky and manage to kill the problem by holding down STOP on the looper a few times, trying again, no good, hold STOP down a few more times and then it is ok.
Hopefully I have explained this problem clearly enough for someone to help. It is just so frustrating. I cannot think of too many situations where a player would want this delay to occur so I’m thinking it has to be a bug in how BB sends commands to the looper.

Unfortunately, I do not own an Infinity to try reproducing your issue.

Just as a guideline - if your problem is being solved through some manipulations with the looper - it simply cannot be the problem with the BeatBuddy. If you pressed BeatBuddy several times, or (I don’t know) twisted a Volume knob to make your problem go away, then it would indirectly show a BB problem.

I know for a fact that my Boomerang III never gave me sync problems before the most recent BeatBuddy firmware update (I didn’t thoroughly test the most recent firmware).

I am not saying all is fine and dandy, the issue you are running into should be investigated. I will be checking the MIDI sync code later this month so I can verify whether it is being done correctly.

Thanks for your reply. I agree with your theory. The interesting thing is that after the update to BeatBuddy firmware 1.29 (I think that is the latest) it solved this issue to a 9/10 level. It was a 2/10 for want of a better way to describe. So, the problem still occurs but much less frequently and is easier to resolve. There was something in that that latest BeatBuddy firmware update that went along way towards addressing this problem. Hopefully some other other Infinity/BB users can chime in.
I appreciate the Boomerang is all good but I just couldn’t bring myself to buying one of those. The Infinity in isolation is amazing. With the BB, it is incredible 9/10 times :slight_smile:

Yeah, it would be great to hear other Infinity users about their experience.
I feel like my Boomerang is in isolation like 7-8 out of 10, but when paired with the BeatBuddy it feels like 11 out of 10 simply because MIDI Slave sync together with Master Track sync (recording loop 3 first) make it extremely easy to control.

Be sure to press the REC button BEFORE the new measure on BB begins. The recording starts on the first beat, so you better start recording before the measure begins; if you try to press REC exactly on the beginning of the measure, often you could lose it. Hope I’ve been clear enough, I don’t speak a good English at all :slight_smile:

For example:
hit REC on 3rd beat

1 2 3 4

The Infinity, by default, syncs to a 4/4 measure. Doesn’t matter what song you’re playing on the BB, the Infinity assumes 4 beats per measure and counts quarter notes. The Infinity will start and stop recording at the start of each measure. The tempo of the song dictates the length in time of each beat. With that in mind, if you hit the record button in the middle of a measure, the Infinity will queue the start or stop of the recording until the start of the next measure. With MIDI sync, there is no point in trying to be exact with your button stomps, the MIDI sync takes care of that for you. Stomp the button anytime after the start of the measure to start recording at the start of the next measure. Stomping the button is like saying “ok, here we go in 3, 2, 1…” recording starts. Stopping is the same thing, stomp anytime before the end of a measure and the Infinity waits until the measure is actually done before it stops. Again, trying to be exact is pointless. By forcing the measure sync, your loops will be in sync with the measures of the BB song. HOWEVER, if you’re playing a song that is not 4/4, you might want to adjust one of the presets on your Infinity to sync to, for example, 12/8, to accommodate a BB song that is in 12/8 time.

The other option is to set the Infinity sync on a beat instead of a measure. You “could” set it to 1/4 for a quarter note, and the Infinity will then start and stop recording the first quarter note it comes to after you stomp the record button. This requires some pretty good timing on your part because you need to be fairly exact (not perfect) as to when you’re pressing the button. One of the advantages of setting it to quarter note is that the time signature of the BB song really won’t matter anymore because it will be up to you to start and stop your loops on the correct beat in time with the song. There is still sync going on, but it’s just syncing a lot more frequently than on a per measure basis.

If you don’t sync the looper and the BB, recording will start and stop exactly when you press the button. This will require godlike timing if you want your loops to be in sync with the BB for any length of time.

I haven’t tried setting the Infinity to half note yet as that would essentially give us a little more time to queue things up, especially with up tempo songs, and still give us the flexibility to start and stop loops in-between measures (half), though I personally don’t ever have a need to make loops that are in a different time than the BB song.

I reOpen this thread because i have the same Sync delay problem.
I have one Digitech JamMan Soto XT (SLAVE) connected to BB (MASTER) with a SyncMan (a MIDI trasformer signal box).

  • Well: I start the BB and, after the Intro, I Rec my loop in Syncro with my BB (AWESOME)!!!; :slight_smile:
  • when I Pause my Song, The BB and Looper Stop to Play correctly. (WOW); :smiley:
  • unfortunately when UnPause BB, the MIDI Tick is no more the same but it’s delayed 1 or 2 beats. o_O

I try to sync my JamMan with my DM1 Drumstation over my iPad and it’s all OK… :eek:
SO, PLEASE, HELP MEEEEE!!! :frowning:

Assuming you’re syncing to 1/4 notes and depending on tempo, your timing needs to be pretty good when un-pausing the BB. If you miss the beat you’re shooting for, it will sync up with the next one and your loop will be out of sync (read delayed). When un-pausing, try un-pausing with a fill as the BB will force you to stay in-sync with the current measure, regardless of when you stomp the un-pause button, such that the main beat will pickup again at the start of the next measure in time with your loop.

Hello Tore!
Where you able to fix that problem? I am looking into orderi g that syncman from France and want to know if you were able to fix that pause/ unpause situation before O order it. Or maybe I should be looking at a different looper?

Hello guilleonline!
Unfortunately I could not fix it. I also updated the syncman firmware but unfortunately nothing. Even with the new BeatBuddy firmware I can not synchronize the start / stop of the loop with the first beat of the drums.

Such a shame! I guess I will have to look at the boomerang 3 or infinity looper instead. Have you tried sync’ing the jamman without midi to play along the beatbuddy? Could it stay in time for a song?

Boomerang III is extremely reliable and syncs perfectly to the BeatBuddy.
However, it cannot store loops - as soon as you power it off, you loose everything. You just need to have this in mind in order not to feel disappointed after buying this not so cheap unit.
But let this not fool you - having to record all your “backing tracks” is enormous practice that lets you achieve much better sounding. And actual sync capabilities of Rang are really unmatched.

Without midi sync, in live situations, it’s impossible stay in time…
One workaround it’s recording with Jamman the drum track and, in live, play the other parts of song.

Such a shame…really…

I don’t mind the fact that it doesn’t have storage. Question does it (the boomerang) obey the pause/unpause functions? And also when the outro finishes does the looper ends as well? Or does one have to manually stop the recorded loops once beatbuddy stops playing?

Yes, perfectly. It can be controlled via BeatBuddy - whether you want to pause beats + looper, or only beats, and leave the looper playing.

Yes, every time an outro ends, a looper stops.

Actually here is another cool surprise - when an intro ends, Rang automatically resumes playing all the tracks that were previously stopped by the outro!

Awesome! Just placed the order for the rang and will be ordering my beatbuddy in a few minutes. Thank you guys great forum with great helpful people!

I am able to sync perfectly with the SyncMan, BeatBuddy and JamMan Solo XT. It did require a firmware update. And it seems to have problems if you restart after a pause withe a fill (by hitting the main pedal rather than the footswitch).