Looper start issue using MIDI with Beatbuddy

#1

Apologies if this has been discussed previously, I can’t find it a solution.

My Beatbuddy and Infinity looper are MIDI sync’d just fine. All timing works as expected. I hope the following makes sense…

Problem: I have a saved preset number selected and ready on the Infinity looper. I start a song on BB by pressing the pedal. This initiates an “automatic” start of playback of the recorded preset loop (while in sync with BB) that I’ve recorded into the looper.

Hopeful Solution: I don’t want the BB to trigger the Infinity to start playback of the loop immediately, but I DO need them to always stay in sync, but not to start the recorded loop preset automatically. I need manual control of when to start my preset recorded loop once the BB song is started (same functionality as simply recording a loop live, and pressing the foot switch to start it once recorded, right before the measure starts).

Any suggestions? Thanks!

#2

sounds like you need to try and change the midi message to your looper then assign your pedal to it.

#3

The only thing I’ve been able to do with the infinity is manually stop and erase loop 1 then manually restart the looper. It does seem to sync but I can’t seem to get the infinity to start recording at the start of the next measure if I do a loop trigger mid measure before when I start recording.

I’ve just been practicing timing of the trigger.

I have not tried it with a preset prerecorded loop though.

One workaround might be to write a longer intro drum sequence to get your song part played before your prerecorded loop starts. Not elegant if you have a long intro but it might fill the need.

#4

BB Midi out settings - keep sync enabled. There are 2 choices. Either all the time, even when B.B. is not playing, or just when B.B. is playing. Midi start - set this as Disabled. You will start the Infinity with its buttons, and it will be in sync with the B.B.

#5

Phil flood. I set the midi start to disable and it still starts the infinity looper when I start the BeatBuddy. Why would this happen? I figured that disabling midi start meant no midi start command. Any idea?

#6

I have no idea why your pedal is not acting the way that the manual clearly states it should. Perhaps something with “loading a song” in the Infiniti puts the Infiniti into a mode where the next action causes it to start. Can you connect your BB to a computer and run a midi sniffer program to see if the Start command is truly disabled? If it is, then the Infiniti is causing the problem. If not, and your BB is sending a start signal, then I would try reinstalling the BB firmware.

#7

Thanks Phil. I think it’s the Infinity. When I load a loop the stop button lights red and as soon as any midi comes in to the pedal it starts the armed loop. I’m really bummed out about this. I really like this looper and the ability to save loops. I’m sure that Pigtronix could fix this and maybe they have and I’m just missing it. I think I’ll send their support a note and see if they have and idea. I’ve dealt the people at Pigtronix before and they are very responsive and helpful. Hopefully it’s user error.

#8

A suggestion, sell that looper get an ipad, get Quantiloop, all problems solved.

#9

Thanks Larry. You sound like you already are using an Ipad for looping. I have an IPad Pro that I’m on right now. What hardware do you use to get midi and audio in and out of the Ipad and which Midi footswitch? If I were to go this route I’d need something I can gig with. Solid hardware nothing flimsy. The little input jack on the side of the Ipad scares me.

#10

Problem solved! Mike Terrile from Pigtronix answer my support request this morning AT 6:24. It was simple of course. “Simply open the App for the Infinity Looper and edit the Global Settings to block or filter any unwanted MIDI Date such as MIDI Start/Stop and also ensure that you have click the check box next to “Ignore MIDI Notes” for the best performance.” AWESOME CUSTOMER SUPPORT!

2 Likes
#11

Thanks for sharing the solution.

1 Like
#12

I have owned many hardware loopers. Once I started with Quantiloop, its not even fair to compare the two. This thing is amazing and has worked flawless, also works awesome with the BeatBuddy. The options you have are mind blowing. Sounds like you really like your Pigtronix. Enjoy

#13

Sorry to report that I’ve sent the infinity looper back and am now using my old trusty Boomerang 3. Even though the infinity does work as advertised there where to many things I didn’t like about it. #1: even though saving loops is not difficult having to bend over every time to load a new loop was a pain. #2 having to push down on the pedal before the measures to record or play back was frustrating. On my Boomerang it is just start on the beat or stop anywhere and the way the bonus buttons were set up very easy to overdub and do single pass loops where you just tap button as you record and stops and waits when you hit the loop button again. Lots of other cool stuff as well like using three loops etc. and more. I can’t save loops which is a bummer. But I have clean slate for every tune. Between using the Beatbuddy, trying to load loops on infinity (sometimes I would forget to change the BB and the loops got real wonky) manage my pedal board, sing etc it was too much and no fun. Now I use the Rang looper more sparingly and it syncs perfectly and I don’t have to think about it. With practice I’m sure I could have got the Infinity to work, but I don’t have the time to spend learning and practicing with it. YMMV

1 Like