Do any of you users have loopers that sync on the beat with the BB ? I have an infinity looper that syncs on the measure which can be quite challenging



I use a Boomerang III looper together with the BeatBuddy since 2016 - with syncs on the beat … well, with a slight delay (latency?) behind the beat if I go by comparing the BeayBuddiy’s visual metronome & Rang III’s blinking led … it works almost always fine but occasionally I’m getting a slight offset which I think could be the (latency?) delay with the BB sending the impuls to the Rang …

This is actually a question to @BeatBuddy_Support and @persist or @BrennanSingularSound - can the sync between the BB (metronome) and the sent sync impulse be improved / aligned …

1 Like

Thanks Ive heard the boomerang works good.do you have any videos of you playing ?

I also use a Boomerang III. I haven’t noticed any problem with latency or the loop being “behind” the beat.

Here’s a video of me setting up Comfortably Numb. You can see the beat buddy and sync-light for the boomerang.

Here’s Superstition. You can’t see the pedals in this one, but you can hear the bass line I looped and the BB drums. Superstition Cover by The Jason & Brandon Duo - YouTube

1 Like

Also, if you do get sync issues with the boomerang, I’ve had a couple issue with the syncing that I just had to tweak a couple settings for.

  • Midi Sync → Start ->BB Intro (Default is Main Song). With this one on the default it can be challenging to start your loop on 1 of the main song because it’s not really synced until the song starts.
  • MIDI Out->Sync=While Playing → This allows me to still do songs on the boomerang where there are no drums, or where I build up a percussion track on the looper the old fashioned way.
1 Like

Cheers @josborn777,

That did the trick - very helpful recommendation indeed :grinning:

1 Like

I have the Ditto X4 and it syncs beautifully!

1 Like

Nice I had one as I couldn’t get it to sync.Must have been my settings

Ditto Jam X2 syncs well

I use a Boomerang III as well and it works fine syncing on the beat. When I’m not using BB for a song, I pop out the card to stop it from sending the clock signal to the looper. I wish the clock signal would stop when I put BB to sleep.

Way easier than that - just follow @josborn777 advise - works like a charm … no need to pop out cards & disconnect BB from etc …

1 Like

That’s been my experience as well. I’m going to try the ditto jam to save some space and does not require midi sync. I plan to plug the BeatBuddy headphone jack into the audio in of the ditto jam.

1 Like

I’m just about to press ‘go’ on the BB sending its clock to a Circuit Tracks (which works, eg for the project loop tempo, triggering external sequencers etc) and then out again via the CT’s midi thru into the Ditto X4 and hoping the whole lot stays in sync! Wish me luck, lol… :joy: