Loops will not loop seamlessly in BB manager

Forgive me if this has been answered before (I’m sure it has) but I’ve been searching the forum and documentation without success.

I’m trying to import my own midi drum tracks and attempting to build a song in the BB manager. But when I import a loop of any length (1 bar, 2 bar, 4 bar) it never loops properly. The loop will play in the BB manager once and then pause for an equal amount of time before repeating. I simply can’t get my loops to loop seamlessly. These are just simple midi drum tracks with standard mapping. Nothing ambitious.

I’ve spent several hours on this without success. Any help would be appreciated. Thanks!

Maybe Phil Flood’s post just before this will help. http://forum.mybeatbuddy.com/index.php?threads/problems-with-beat-buddy-manager-timing.7655/#post-33321

Thanks for your reply. I had seen that thread. And I’ve been experimenting with it for a while. Scrutinizing my beats and placement. I’m sure I’m doing something wrong and it’s probably something simple. There’s a face palm in my future for sure. Thanks

Export the offending track from BB Manager using the BB Manager’s export as midi command (right click on the section in Windows, control click on a Mac. The option to export will appear. Then reopen that exported track in your DAW. My guess is that you will see blank space at the beginning of the track.

Yes, this. I had been lining up my Logic tracks to beat one. But I found when I reopened them there was indeed space at the beginning. Seems my problem is a Logic export one and not a BB Mgr one. I need to export, save, reopen and save again… tedious but it is working. At least I understand what’s going on now.

Thank’s for your reply.

Along with lining up your logic tracks to beat one, you also have to have something in the Logic track through to the last best in the section you want to export. Assuming you are dealing with something in in 4/4, for example, you could find your last kick drum in the section, again as an example, and simply extend that midi event until the end of the 4th beat in the last measure of the section. Do not go past the end of the section even by a tiny bit or Logic/BBM will add a new measure. What I usually do is extend the note to just before the end of the measure. This seems to cure the problem.