May 2019 Update "write protected" my SD cards

I ran the May update a few weeks ago (the complete library from the downloaded ZIP file, not the incremental update), as I’ve done for the last 6 months or so. It installed without a problem, as usual, on both the 16Gb BeatBuddy Premium Library SD card, and my 3rd party 4Gb SDHC card. The June update is now out, and after downloading and attempting to install it, I’ve discovered that both of the disks have been write protected, and not via the lock slider on the card. This appears to be software based. Attempting to remove disk attributes via the CMD prompt was not helpful. Reformatting was unsuccessful, which was not unexpected. Currently I’m in the process of deleting the entire partition from the 4Gb 3rd party SD card. Anybody else experienced this problem? I’m looking for potential cause and solution, please. Thanks all!!

Have you received an answer from Singular Sound or have you resolved this issue yet and if so, how did you get it fixed?

Yes, I emailed tech support and received a reply yesterday. They are sending me a new card, which is cool, but I would really like an answer as to how this happened, which I have not received. At this point, both of these SD cards are useless. This was something in the code of the update, which hopefully will not reappear. I know that it was nothing I did, and I can’t believe that I’m the only person to have experienced this.

I Googled your problem and in the link below if you’re comfortable poking around in the registry Option 2 may offer a fix if you haven’t already tried this.
There is also a download from Easus in that link below that supposedly can format a locked SD card. I’ve used their software in the past to partition a drive and had no complaints the way it worked.

Have you run a virus scan on the cards?

1 Like