MD-BT01 shows as "offline" in Onsong

Hi, I have used Onsong to select my MIDI songs on BeatBuddy for a couple of years and have never had a problem. I have not been gigging with this setup for a few months now due to the pandemic, but in starting it up to practice, I cannot get the MD-BT01 connect. I would always go into the MIDI editor, select connections then tap the Bluetooth Icon. Then MD-BT01 would show up as “not connected” and I would tap that to connect. Easy. Always worked.
Now I go into the same spot and it is showing the BT01 “offline” Is this likely a pedal setting on the beatBuddy or the firmware update a few months ago? I cannot get it to connect now.

It happened to me as well, after the latest Onsong upgrade. So, I went back to using the midimittr app (free from Apple Store) that I used to use sometime ago, which always seems to work. Then, a couple of weeks ago I decided to connect Onsong directly to the MD-BT01, again, and it’s been working since then, sometimes after a second attempt. That’s all I can contribute with for now.
But if it says “Offline” make sure the MD-BT01 MIDI Out connector shows a red light. If it doesn’t, you may have switched the two ends inadvertently (or doble check the connection)
Cheers!

Actually about an hour after I had submitted this, I stumbled on the issue when I was going through some of the iPad settings. I realized that somewhere between then and now, MIDI had been turned off for OnSong. Duh! Now that is working fine and I’ve just got to figure out how many other settings I screwed up trying to fix this. LOL

1 Like

Just as I was reading this! Glad It was solved!

I always thought I had to connect my MT BD01 via another app as this was a Yamaha / OnSong glitch. Having read this I have tried again and now can connect directly. Thanks for posting!

1 Like