MIDI Maestro didn’t connect

Already had the Aeros and BB, they have worked fine and still do. I bought a midi maestro today and I was assuming it was just plug and use but it doesn’t seem to be controlling either yet the BB seems to be controlling the Aeros.

I updated the firmware on all 3 and I have the midi as follows… MM out to BB out to Aeros. I have the Midi settings on the BB set to “merge”

Is there something else I’m missing? Some other setting I missed? It’s just not controlling either the BB or Aeros at all.

To be clear…
All firmware is up to date
BB midi set to Merge
If the 3 are connected, only the BB and Aeros communicate
If the MM is connected only to the Aeros, it controls it fine

You should have the MIDI Out on the MM connected to the MIDI In on the BB breakout cable. And then the MIDI Out on the BB breakout cable to the MIDI In on the Aeros.

I have all three and it works great for me.

Yes I have that and it’s not working, which is why I’m confused

Did you update the “default mode” on the Maestro?


Sorry…just going through the steps in my head…

Have you tried to connect the MM to the BB only, and use the MM BB Mode to control the BB? Does that work? Then have you tried to connect the MM to the Aeros only, and use the MM Aeros Mode to control the Aeros? Does that work? And it sounds like the BB and Aeros work together when the MM is not part of the equation. If all that works properly, then it’s not a cabling issue, but either some setting is off or your MIDI commands are incorrect. Are you trying to use a Custom Mode or the built-in BB or Aeros modes?

1 Like

The problem seems to be BB input…
BB to Aeros works
MM to Aeros works
MM to BB not working

Maybe the BB breakout cable (MIDI In part) is the culprit then? I’m assuming you used the same 5-pin MIDI cable from the MM to the Aeros, so that would rule out the 5-pin cables.

1 Like

So since I didn’t really plan to use MM with the BB anyway but still need BB and Aeros to sync, I just ran midi out of BB into MM, out of MM into Aeros and that’s good enough for me.

I believe the problem was from a malfunction of the input part of the breakout cable.

1 Like