Midi Maestro Settings for Boss RC-505

I’m trying to use my MM as a Midi foot controller for the Boss RC-505 looper. I know that the MM is sending Midi signals and so that’s not the problem. I’ve been able to connect the MM as a controller to Ableton Live, and so I know it works. I’ve tried every possible setting in the RC-505 system and memory settings folder, but not had any success. Has anyone else here been able to use the MM as a foot controller for the RC-505?

@zwilson
Hi try this linked video, it has some good tips on RC505 midi control.

https://youtu.be/RzHba0Eh1p4

As long as the channels match, the MM will send CC and PC commands to pretty much every midi device. Mine currently does a great job controlling a Boss RC10R.

Thanks for the reply. I’ve tried to set both the MM and RC-505 to send and receive on CC1 but not had any luck. At the end of the video the guy talks about another midi foot controller that he couldn’t connect to the RC-505 and maybe that’s the case with me. I was just wondering if anyone had any success with the MM.

@zwilson
Ok try these settings:

RC505 - Midi Receive Channel - Set to 1
RC505 - Midi Transmit Channel - Set to Rx
RC505 - Midi Omni Mode - Set to Off
RC505 - Midi Program Change - Set to Off
RC505 - Assign Source - Set to CC#1
RC505 - Assign Target - Set to All Start/Stop
RC505 - Make sure Assign Target - CC#1 - is not set to transmit cc

MM - Command Name - RC505 All Start/Stop
MM - Device - RC505
MM - Description - RC505 All Start/Stop
MM - Type - Control Change (CC)
MM - Channel - 1
MM - Command - 1
MM - Value - 127

You could try a program change command to see if this works

MM - Command Name - RC505 Memory 5
MM - Device - RC505
MM - Description - RC505 Memory 5
MM - Type - Program Change (PC)
MM - Channel - 1
MM - Command - 4

Also make sure the midi cable is fully seated in the MM, sometimes the protective sleeve on the plug prevents the cable going fully into the MM. Let us know how it goes, good luck!

The first set of settings using CC did nothing. The second set, using a program change command, resulted in a change from memory phrase 01 to 02, which tells me that a signal is being sent for MM to the RC-505 but it’s not doing what it ought to.

Same issue here with the RC202. I don’t think anyone here has actually had a working set up with either the RC202 or RC505.

If you haven’t figured it out yet and you still have the MM, I just did on my RC-202, so here’s the trick.

For each command you want to do on the RC-505, you actually have to send two commands. Let me give an example (but it’s true for every function on the looper):

Record/Play (I set mine to CC81)
Down
Command: 81
Value: 127
Up
Command: 81
Value: 0

The looper activates the command on 127. Without resetting to 0, it won’t initiate the command again.

1 Like