Midi Maestro Tempo Change

Hello -
I have a new (7/22/22) Midi Maestro. I really like the idea of using it with my BB, but so far it’s been quite the rocky start.

Initially, I had an older BB firmware, and didn’t check the MM firmware, but it’s whatever it shipped with. Remember, it’s brand new.

My MM only seemed to have one problem but it was a pretty big one. the tempo was frozen at 1 BPM and there was not increasing it. The few other things I tried seemed ok, I could start and stop a beat, I could apply a variety of accent hits, moving through folders seemed fine. Just could not change the tempo. Not even with the tempo knob on the BB pedal. So, I updated firmware, thinking that would help.

I have updated the firmware on my BB 1.4.1
I have updated the firmware on my MM to 1.7.1 using my iPhone and associated app.

Now nothing on the MM works. The buttons press and the message changes on the MM screen, but the BB doesn’t do whatever command you selected.

I rolled back the BB firmware to experimenting to see if that helps. Now the BB is stuck on 300 BPM. I can get accent hits but they latch (stay on unitil you hit the button again, but sometimes taht doesn’t work) You can get the BB to start and stop a beat, but again, 300 BPM and no moving the tempo. Half time and double time do something, but not sure what. The BB responds, but not sure what it’s doing really. Overall I would say the MIDI layout is a mess and needs to be straightened out somehow, but I don’t know how or what to do on that behalf. The hardware seems ok from what I can tell, all cables are brand new.

My goal for using the MM was to just hook it up and use it in default BB Mode and nothing else.
If I could get to a point where that is possible, that would be very good.

Did you update the default mode? if not , do it
You can find this in the menu of the app

Reset the default Midi settings of the BB and try again

Connection is Midi Maestro OUT to BB Midi IN ?

midi settings of the BB is to “MERGE” ?

Hey NYHC -
Thank you for responding!
In the interest of full disclosure, I have re-updated my BB to firmware 4.0.1. I am now back to the MM pedal doing nothing at all, but read your entire post before proceeding and felt that maybe having the latest firmware on both devices was the way to go…

I went under midi settings (pressed drum set and tempo simultaneously on the BB pedal) and selected restore midi settings by pressing the tempo knob. I pressed the temp knob a second time while selecting YES.

Just to be sure, I even did a reset BB settings on the pedal for good measure.

Tripple Verified; the BB breakout cable is clearly marked which connection is out, and which is in. The OUT on the BB cable goes to the IN on the MM and The IN on the BB cable goes to the OUT on the MM. I also made very sure everything was pushed together tightly.

Under the Midi OUT on the BB Pedal, it is set th MIDI-MERGE

Under Midi IN on the BB pedal, it is set to OMNI. I read on another post that someone having similar problems had luck changing to Chanel 1, so I tried that. So with the Midi IN and the Mid OUT both on channel 1, I have marginally improved things by at least getting wildly incorrect responses from by BB pedal. It makes strange noises, when I hit certain buttons. I have been able to stop the strange noises (which may be the selected beat at 300 BPM). The horizontal scroll bar on the BB screen races wildly across. When I tried the folders, they also raced wildly, but it looks like the MM and the BB are at least talking…
Setting the Midi in and the MIdi Out on the BB to the way it was, resulted in status quo; the BB pedal seemingly ignoring the MM…

I appreciate you reaching out ant trying to help me. Thank!!

Hey, wfrance3,

I think what NYHC was asking was if you also updated the Default Mode on the MIDI Maestro. Updating the MM is a two-step process:

  1. Update the MM firmware and when done
  2. Update the MM Default Mode.

Hey persist -

Absolutely. I did update the MM firmware. I’m at 1.1.7
Also did update the default mode; on my iPhone app, went to other-updated default modes, and then started the little connecting routine and started counting up to 100%. - Nothing stalled or hung up. Apart from it not working, the process looked pretty good.

Hello wfrance3
I ask you for the connection .
But I see that you connect the Midi In & Out of the Maestro ?!


Just the Midi out of the Maestro into the Midi IN of the BB

Hey NYHC -
Yes, I did connect both. I don’t know anything about MIDI and the breakout connector has a midi out and a midi in, as does the MM, so I figured that’s how you were supposed to do it…

I have pulled the cable you said. I now only have a midi cable running from MM Midi OUT to BB Midi In via the breakout cable. So the OUT on the BB breakout cable is connected to nothing, and the Midi IN on the MM is connected to nothing.

Still same behavior as before.

On the MM I re updated:
Update Firmware
Update Default Modes
(in that order)

On the BB i re updated:
Main Pedal - Midi Settings - Restore Midi Settings

Just for good measure, after updating, I turned the power to both pedals off for 30 seconds and then back on again just in case that had anything to do with anything…

After trying all, It works!!

Appreciate your awesome and prompt help!!

Thank You!!!


1 Like

Just kidding. - I’m sorry NYHC. It did work great. I turned the power off to everything for maybe 20 min. and then was going to practice for a bit. I’m back to not working again. Weird. What do you think might be going on?

If you have resetting the Midi
Go back take a look if the Midi is to MERGE

I thought I had this licked, but it turns out I’m still having trouble. See previous thread:

Midi Maestro Tempo Change - Midi Maestro / Help, Questions and Bugs - Singular Sound Forum

Short version of the story, all I want to do it get my BB working with my MM.
I received some very quick and good help, but unfortunately This fix didn’t stay fixed.

I have updated Beat Buddy firmware and Midi Maestro Firmware.
I have all new cables.

The one thing that I did was use a two button switch with the BB plugged into the TRS Footswitch socket om my BB. I changed the wile playing value for switch two to stop with outro. I change the wile playing value for switch one to pause/unpause. If that was a mis- step, I can live without that stuff.
Would really like to get this working. If anyone has any ideas they would be very much appreciated.

It seems that you’ve done everything you can possibly do. Although you mentioned that you have new a new MIDI Sync Adapter for your BeatBuddy (BB) pedal and MIDI patch cables, it could be that one of those cables is defective. Some users report that to be case. The fact that you had it working before, turned it off for 20 minutes and then turned it back on and it was not working is an indicator that you might have a defective pedal or cables. Now it’s probably time to isolate components and see if you can identify the problem.

If you have another MIDI-capable pedal (looper or delay), try connecting the MM and cables with that other pedal. Keep in mind that you’ll have to configure both pedals’ MIDI settings for the test. Make sure you are using the power adapter (PSU) that came with your MM. Does the pedal respond to any of the MIDI commands from the MM? If so, turn everything off for 20 minutes and then test again. If they still work as expected, it’s on to repeating the test with the BeatBuddy (BB) pedal. If everything tests fine with the BB, it’s time to contact support@singularsound.com for help.

To keep your posts connected, I’m merging this thread to your original. When you reach out to support, please provide him with the link to that thread. Once you get everything sorted out and working, please circle back and let us know what you did to get it working.

Just Checked, I am in MERGE

It turns out that this is the case. Once I got everything working, I (OCD) straightened up my cable nest I had going and must have disturbed the shorting cable. I need to do some more experimenting to see if it’s the breakout cable or the midi cable itself, but one of them is shorting. when I jiggled the cable, it was all better. - Thank you again for hanging in there with me on this. fingers crossed I don’t need to bug you on this more. You have been very patient with my Noob-ness. I will include the ling to this thread with the email that I sent to support@singularsound.com previous to discovering this forum.


1 Like


Glad you’ve sorted it out. Holler if and when you have other issues.

Thanks again for your help!!

1 Like