Midi maestro - upper right button not working

Having a problem with fresh out of box midi maestro, hope someone can help:

  1. Tested midi maestro with beat buddy and upper right button does not work for any of the functions. All the other buttons work.

  2. Updated firmware and same result.

  3. Tried a different midi cable with same result.

  4. Tried to use it with Aeros, but could not get into Aeros mode because upper right button does not work. :frowning:

If you bought it directly from Singular Sound, it is covered under warranty. Contact support@singularsound.com

If you bought it new from another vendor, you’ll have to work with that vendor.

If you bought it used from a private party, you can try to negotiate a return.

Some other things to try:

  • clean the switch with compressed air;
  • treat the switch with DeoxIT Contact Cleaner;
  • delete and reinstall the app on your phone and then reinstall the firmware and Default Mode to the Maestro.

Let us know how you get it working again.

I was tired of messing with it, and didn’t think I should have to go through that, so I just returned it and bought another had it shipped 2nd day.

1 Like