MIDI Raw Hex

Can someone please tell me the raw midi hex to change tempo?

I’ve gone to the download page and although the user manual says there is a seperate midi manual I can’t find it.

I am reusing beats (don’t want or need a different preset for every song) so I want to send a standard preset (like rock 1) and then send hex to change just tempo.

Not sure that the Midi Firmware Settings on the Downloads page http://mybeatbuddy.com/downloads/ (right beneath the blue BeatBuddy Manual download button) contains hex settings.

If you are using some hardware or software other than just the BeatBuddy, it might be helpful to know as there are several users that could probably help you if they knew some more details about your configuration :confused:


I’m not sure you can go straight to a specific song, so you might have to navigate to the folder containing the rock1 song, and then select the rock1 song.

Google Hex to Decimal conversion for the translation.

I got it figured out. The midi manual wasn’the showing up on my phone but I found it.

For those using Set List Maker wanting to pull up a standard beat and then change tempo…

In midi presets, add the beat in program change for example 0 0 2 for first folder, third song.

Then to set the tempo in raw hex code put

B9 6A 00
B9 6B 7C

This sets tempo to 124 (7C is 124 in hex)

My problem was SLM format, I didn’t know exactly what info should be sent and order.

Thay is the format , it should work
b9 6A 00
b9 6b 6e

Copy and paste that. It should change tempo to 110

I setup separate preset’s for tempo

It’s the last 2 in each that set the tempo. So play around with that for different settings.

I am using SetListMaker to transmit my change information. I am able to change songs on the BeatBuddy with no problem. When I create new presets to try and change the tempo, the change is not happening. I’ve used
b9 6A 00
b9 6b 6e
in the hex area of the SLM Preset …

SLM show that b9, 6a, 00, b9, 6b, 6e is being sent to the iRig 2 port … however the change doesn’t take effect on BB.

Anyone have any suggestions? What am I missing here?

You have the correct hex numbers. I would suggest connecting just the BB with SLM only and then create a new test preset and send those hex numbers manually within the preset itself and see if works and then go from there. I have this set up and working. So it does work. Also make sure you have the latest firmware on BB.

b9 6A 00
b9 6b 78

This example should change the tempo to 120

JStrausss … thanks for the reply. I tried creating a preset to just send hex for tempo change. Still no joy! I updated the BB firmware just a couple of days ago to the latest version, so that is OK.

Can you post a screen shot of your test preset setting in SLM? If I can see how it’s setup I can compare it to mine. Also a pic of how the BB is physically connected to you device. What devise are you using to run SLM?

Can you post the hex you are sending to set the folder/song please.

You’re not going to believe this … but … I set up my iPad and BB so I could snap a photo of the setup and do some screen shots. This time it works! Maybe the iPad had some kind of glitch that was cleared by pressing the buttons for the screen shot? It doesn’t make sense to me but that’s what happened. And, I’m not sure if this is what’s supposed to happen, but EVERY tempo for EVERY song is now 120. Tempos do get reset to defaults when I reboot BB.

here’s a screen shot [ATTACH=full]3151[/ATTACH]

O good at least it’s working. That sample hex number is for tempo 120. So what ever preset has that it will set it as such. You will have to adjust the 00 of the first hex and 78 of the second to change the tempo to what you want it to be for that particular song.

Well that hex code your are sending to the ‘bb’ is going out on channel 10 if that’s of any help.

I think in the iPad version of SLM there is another way to change tempo. Have you experimented with - send midi beat clock - setting in SLM?

send timing (beat clock) messages in Setlist maker

[]Navigate to Settings > Tempo & Pitch and enable the “Send MIDI beat clock” option.

]Edit a song and enter a tempo value. You can enter a number, or use the Tap button to set a value.
[]In any song list, tap the Tempo button for a song. The icon will begin flashing, and the beat clock messages will be sent. If you select another song by tapping it, using a Bluetooth foot switch, or swiping through your documents, the beat clock will change to match the new song’s tempo. You can stop the beat clock by tapping the active tempo button again.
]To send the MIDI beat clock only to a specific port, you can change Settings > Tempo & Pitch > Tempo Options > Send Beat Clock to Port. Otherwise, it will be sent to all available ports.

Big E … right you are! I was screwing around with different iterations of different settings and didn’t change that back to Channel 1.

JStrausss … thanks! I already had “Send MIDI Beat Clock” enabled … also have it set to send to “ALL” ports