MIDI-Sync with Voicelive 3 Extreme won't work

HI all!

I’m new to using BeatBuddy and trying to achieve something pretty standard for two days now: The BB tempo shall be automatically synced to my TC-Helicon VoiceLive 3 Extreme.

I bought the official MIDI breakout-cable, connected the BB-MIDI-Out to the VL3X-MIDI-In, checked the settings on both devices a hundred times, according to manuals and tutorial videos, but still the devices won’t talk to each other. At first I tried BB firmware 4.1.0, later downgraded to 4.0.1, but that didn’t make a difference.

Obviously the BB-MIDI-settings have become much more complex over time, and so I’m looking for anybody who successfully brought this sync to work and can share their settings with me. I’m happy with any hints.

Thanks in advance.

1 Like

Not familiar with the MIDI settings ob the VL3X, but I/we still might be able to help. We’ll need more info:

  • Which device is the timing master?
  • What channel are each of the devices on?
  • do you want them talking to each other, or do you want one driving the other?
  • What are you trying to get the devices to do?

More info might mean more help.

Hi, my BB & VL3x are packed away at the moment so can’t check exact set up but after my initial struggle I’ve had these syncing ok for ages. I followed this video to set Temp on BB so VL3x will follow….

Hope that helps. If you’re still struggling I’ll check back when my equipments set up again.

1 Like

Hey, thanks for your reply.

For starters I had planned to make the BB the master (one-way-communication). Both devices are set to channel 1, but I also tried switching to channel 2. The only thing I want to achieve is to automatically match the FX-parameters (e.g. delay times) to the BeatBuddy‘s BPM.

Hey Carl,

Thanks for your reply. I know this video and tried to follow the exact steps. But the guy in the video must be using an older BB firmware, so I could not find the options he showed.

Anyways, incoming MIDI messages on the VoiceLive are regularly visible in the display, which is shown in the video. This is why I know the devices don‘t communicate.

So the one that catches me out is Midi source on VL3x - make sure it’s not USB. Then ensure Midi tempo is On. Apologies if you’ve seen this in the manual.

And on BB for BPM master use these settings, I’m not aware they changed over the new software releases so if this doesn’t work I’ll definitely dig out my pedals and take images later. I’m sure we can get sorted some how.


Looks like bigger brains than mine beat me to it. And they did a better job than I likely would have.
It’s a great community here.

Thanks guys for all of xour input. I already have made sure that the settings are like you suggested, but still it doesn‘t work. I‘m beginning to think about a possibly defective breakout cable and/or MIDI cable, but both items are brand new. :frowning:

Do you have other midi items to check those cables with? I’m sure you would have done that if so, but yes, rule out cable and physical connection problems 1st if you can.

And I’m getting a distant memory / nagging feeling about the VL3 metronome - so check that’s on and loop mode is not in ‘free’.

Hey…saw your dilemma while on vacation and didn’t want to weigh in until I got home to check my settings. I have used the BB and VL3x for several years with pretty good loop sync ( every once in a while it doesn’t sync perfectly but it’s usually because I use a lot of Brazilian , Latin and shuffle beats ) . I also have found that on the VL3x in looping mode I get the best sync when set to quantize . Also to sync the “ metronome mute “ needs to be set on the VL3x. I have both units set to midi channel 1. The only difference in my set up is that I have a Yamaha midi doggle between the two units hooked to the midi out of the VL3x and the midi in on the BB. This enables my iPad to control the BB wirelessly thru the OnSong app. I don’t know if I have missed anything in the explanation. I hope this helps and sorry for the late response.

Also…here is my pedal board set up that I use almost daily…

Make sure the midi setting on vl3x is set on midi tempo as ON.
Go to setup on the vL3x scroll horizontally. its the first option on the right.