Multiple instances of the same song playing slightly out of sync-weird issue

Just got my BeatBuddy pedal today and absolutely love it.

OS: MacOS High Sierra Version 10.13.5
iMac (Retina 5K, 27-inch, Late 2015)
BeatBuddy Firmware version: 2.0.4

When I first unboxed my BeatBuddy, the pedal worked great. I downloaded BeatBuddy Manager (1.64), hooked up my BB and imported my SD Card. I created the backup folder (placed it in my “Documents” folder) and also placed my BBWorkSpace folder in “Documents” as well.

I then created my own song using files already in the BB. So, I have introduced no files foreign to the BB.

Everything seemed to be working just fine. Testing within BB Manager works perfect. I then synchronized and all went well. I then unconnected BB from my Mac and plugged it into my amp (as I had done when trying it out the first time, when it worked perfectly) and began going through the presets again. Now, it seems that at least TWO files are playing at once when I click the pedal to play, I believe it’s the same file playing twice and slightly out of sync.

When I play the songs from BB Manager, everything sounds perfect. I can go to any song, click the BB Pedal icon and the sound is perfect. I click to “sync” and it says that I’m already sync’d. So I deleted all files form my SD Card and re-exported my backup file to the SD Card. Same problem. I’ve wiped the SD Card clean several times and have the same “ghost drummer” thing going on for all presets. It’s like two versions of every song are on the SD Card and playing at once but they’re out of sync. Not sure why I can get perfect play from BB Manager but can’t get it to transfer the clean data to the SD Card. Yes, I’m using the SD Card that came with it.

I can’t even think of key words to use to search the forums so I have been reading the forums for hours using different key words but nothing is coming up. Not sure I’ve done an adequate job describing my issue but hopefully someone out there knows what’s going on. Thank you in advance for the time you spend helping newbies like me.


Well, I just started from scratch and went through all the steps again and everything is working fine. Thanks anyway.

Glad you got it sorted out. Does your amp by chance have a built-in delay that could have been getting triggered? I’ve never heard of the problem you described, but a corrupted file on the SD card can do all sorts of odd things.