My mac won't recognise my SD card.

Hi, my mac running OS X Yosemite won’t read my SD card, either in the SD slot, or connected via USB; MY Beatbuddy is running an older version of the firmware, also I want to import song files, and use the editor.

Any help gratefully received Jaberwock

You will need to use an SD card reader, the current firmware is not recognised by the Mac.

This has been discussed numerous of times but I appreciate it is difficult to find, although the official BeatBuddy tutorial does make mention of this. I believe the latest Beta firmware resolved this - however I don’t have a Mac so don’t know for sure.

Thanks for your reply, I tried an external USB card reader connected to my I mac, but this wouldn’t read the SD card either; would it be better to update the BB firmware on a PC running windows ?

 Regards Jaberwock

PS A link to previous threads on this subject would be great.

I have tried the SD card in a USB card reader with my Imac, and mac book pro, neither of these recognise the card, so I’m assuming the card is formatted in a way that’s unreadable to Macs; my Beatbuddy is running firmware 1.2.9, does updating the firmware to the latest version solve the problem ?
I’ve read through older posts relating to the problem, but didn’t find anything that helped.
I have the latest version of the Beatbuddy manager installed, but I’m unable to open the data on the SD card as the computer can’t see it.

Anything to point me in the right direction would be highly appreciated. Jaberwock

If you are using a card reader the BB firmware version or operating system should not make any difference. All that is stored on the card is a number of files and folders. So this is the same as with any other SD Card you might have. It could be a physical fault with the card or the data on the card might be corrupted. If you have a backup then I would suggest reformatting the card and loading the backup. If you want just the standard songs and drumsets that come with the BB I think these are available for download (please check). In that case you can try re-formatting the card or get a new card (a standard one will do) and load the standard files onto it via the card reader. Of course it could be a fault with your card reader, so perhaps you should test that with another card first. Hope this helps, Tom

Hi Jaberwock. Please see Conversation I started with you (blue icon or envelope icons in upper right corner of this thread).

Sorry Persist, I didn’t see that…

Hi, first off, a great forum, and thanks for all the generous advice, and help.
The problem lay in my card reader, which I bought several years ago, and wasn’t able to read to read current SD cards; with a newly purchased one, I’m seeing the SD card as “no name” and I’m ready to proceed.

Thanks again, wonderful to find such a friendly, and helpful forum Jaberwock