New BeatBuddy Firmware (3.2.0 "A New Look!")

Hi @persist, love v3.2.0, but have a problem whereby the BeatBuddy keeps freezing (displaying something like: no SD card … or the like) when I step quickly up or down through the song list using the external BeatBuddy footswitch … I then have to stop & wait for a couple of seconds bfore the display comes back & I can carry on (slowly) stepping through my songlist - bug in 3.2.0?

Pretty sure it’s a bug. Although I can’t replicate it, at least one other user has reported the same thing.

Singular has had another beta firmware in testing for quite a while now and they must have found some more issues that need to be fixed.

We’ll investigate this.

Cheers David - looking forward to hearing back from you.

just updated to new firmware and noticed a problem—when i switch songs (using onsong midi)
the large tempo screen pops up and takes forever to go away— any way to fix this—
i want to see the normal song screen to verify the correct song was loaded

I’ve had that problem even before the firmware update.

Hi Guys,

We have a new beta firmware version (3.50) that fixes a few bugs. @Shaffer_Ogle_Lee @Skwearlswife @TheWolf2103 please test this to see if your issues still appear. Thanks! :slight_smile:


  • Fixed Missing Audio bug (probably)
    • Missing audio bug was caused by memory corruption during file loading. An invalid library configuration seems to be the issue. (Disabled word access in ff.c to solve the issue)
  • Stability improvement (That were done while looking for the memory corruption problem)
    • Stopped using malloc / free for i2c packets.
    • Limited the number of settings that can be saved in one setting Task call
    • Add load sanity checks to limit the chance of trying to play a corrupt song
  • Midi Time signature
    • Made sure the values sent are valid by applying mask on the payload value (0x7F)
  • Fixed count-in color style
  • Fixed Headphone volume random display
  • Prevent Song Manager from setting default song tempo / drumset if those were set by MIDI 500ms before.

BeatBuddy firmware (398.0 KB)

thanks David, will load it tomorrow and get back to you!

1 Like

Did they fix the “Won’t pass CC102 (Next Part) commands when in MIDI MERGE Mode” bug?

loaded the update–much better.
the tempo screen stil pops up occasionally, but only stay up for a few seconds.
this definitely fixed the proble for me–thanks

1 Like

No, this has not been fixed yet. Next update, hopefully.

Fingers crossed…


1 Like

Hi @persist & @DavidPackouz ,

3.50 installed flawlessly - ran it for 2 gigs now & it seems stable so far - thanks a lot!! Will continue to monitor & report back.


1 Like

Pause/unpaused goes to beat 1 immediately instead of keeping time in the background. It throws out of synch my loop (midi). Before it worked more like a mute.


I responded on your other thread, but, basically, that is the default behaviour – which the firmware update likely reset. You’ll have to go into the pedal and change the setting back to Mute.

No idea what the setting is, because I don’t use it, but you have changes it in the past, so you already know what you need to change to get the behaviour you want.

As mentioned

Hi Kevin (and all).

This may be a good suggestion for you and everybody else who uses the BB the way you do but I would not like the BB to do that by default. I suggest having it as an option in the configuration of the main pedal. That will suit most people, I think. Cheers!


You want to enable the Mute Pause setting: Settings > Main Pedal > Mute Pause > Enable