New Firmware and gigging (is it holding up well???)

Hi Beat Buddy wizards…

I am always a little reluctant to jump on new software releases since I gig 2 - 4 times a week typically with the BeatBuddy and things work very, very well right now (I like some of the new features but I am not sure if it is solid for prime time yet)…anybody been gigging with the new firmware or at least really running it quite a bit?

All positive experiences? Any known issues with the release?

Hopefully my hesitation isn’t seen as a negative comment towards Singular…the BeatBuddy has been very good to me…I am just overly cautious I guess.


I know for a fact the single tap outro is a god send to me

Had a gig this weekend with the new firmware. I didn’t change anything with the new changes and the Beat Buddy ran exactly like it did before. I had no issues. I was nervous about it too as OnSong updated so I had two potential changes and everything worked as planned.

@timalloy6711, yes, one of the features I am interested in, thanks.

@Bootsy, I use OnSong as well with the PUC+, thanks for the response! I’ll probably update over the weekend…

Unfortunately not, I installed, traveled to a gig, to find the Pause and then Hold main pedal to end song no longer worked. I figured it might have been a bad FW update, but I just removed, downloaded again, installed, and can recreate. See email to Singular Sound:

The main pedal no longer stops a song when the pause function of footswitch is used, and the main pedal is held. It either (by default) starts the intro, or when changed via menu, starts a fill. It appears the Tap function is recognized, but not the Hold. I deleted firmware files, downloaded a second time, installed, and the same thing occurs, so I am able to reproduce this.
[SIZE=3][FONT=arial][COLOR=rgb(34, 34, 34)][/FONT][/SIZE]

I installed 1.85, still had the same issue. Reset to factory default. Bug gone. Installed 2.04, now functioning correctly. Weird, but something was causing it. I use this feature for about 3 or 4 songs every gig (when or if I miss cueing the outro), so it’s important to me. The workaround was to pause, turn down the volume, double tap to cue outro, and then turn up volume once the song was ended.

Now to test everything else since I reset to factory! lol

SOLVED. Thanks to Jay at Singular Sound Support. My pedal was set to Main Pedal > Start Beat > Press (not the default, Release). I must have accidentally changed it after the update and didn’t realize it, or a gremlin did it, one of the two.

1 Like

@c.granger thanks for the follow up! Phew!

So I updated Wednesday and took it out for a gig tonight…happy to report it worked perfectly! (sound of me sighing with relief).