New user- need help with downloaded artist packs

I downloaded the Black Sabbath and Soundgarden artist packs. Before installing those I downloaded the Firmwear, Drumsets and Content updates. Everything seemed to work fine but the artist pack songs aren’t making any sound. I can see all of the tracks and everything in Manager just not any sound. Is there a step that i might have skipped on accident?
Thanks in advance.

Delete the artist folders you imported to the BBM.

Save the project. Quit and then relaunch the BBM.

Delete the artists packs you downloaded.

Download and unzip the artist packs again.

Save the project.

Preview your songs.

Use the BBM to import each folder again.

Thanks, I followed everything step by step and still not getting it to work. Seems like only the standard drum kit is making sound.

Both artist packs use the Rock drum set. Both packs sound fine in my BeatBuddy Manager (BBM) so I’m thinking that this could be caused by a bad download of the Rock drum set.

To test this theory, go to the default Rock genre folder and play Rock 1. If it plays and you can hear the song, then it could be something else. If you don’t hear the drums, try this:

in the BeatBuddy Manager (BBM), click the Drum Sets tab and make sure the box is checked for the Rock drum set—if it isn’t, check the box and then audition your artist packs again.

If it still is not sounding, you may have a drum set file that did not download correctly. Do this:

  • In the Drum Sets tab, hi-lite the Rock drum set;
  • BBM > Drumsets > Delete Drum Set and approve the deletion when prompted;
  • Quit the BBM;
  • Relaunch the BBM; the Rock drum set should not appear within the Drum Sets tab;
  • Go to and download only the Rock 2.0 drum set;
  • Unzip it;
  • BBM > Import > Drum set and navigate to and select Rock.drm and press Open;
  • In the Drum Sets tab, check the Rock checkbox;
  • Save your project;
  • Preview your artist packs or songs in your Rock genre folder.

Please let us know the outcome. If it doesn’t work, contact Support, and provide them the link to this thread so they can see what you’ve tried so far.

1 Like

I reinstalled Default Content v2.0 and everything seems to be working fine now. Thanks again for your help!