No audio on iMac Monterey notarized BeatBuddy Manager (BBM)


Can you help me please I upgraded to os Monterey on my iMac. My BB Manager now has no sound and visually it does not appear to play the songs or midi files when the virtual pedal is pressed once or even twice. It doesn’t play at all and the screen greys out. I have tried the following steps:

Moving all its files off the iMac into an archive file. Emptying the bin and then downloading the Mac notarised firmware

Still nothing

I have also tried completely starting with a new SD card and re-downloading all the software from the Singular Sound website. Nothing,.

I have also used another blank SD card to load from the website all the default content to my wife’s MacBook Pro also on OS Monterey. It all works fine on that machine and the same version of OS Monterey.

Can you help me with any more things I can try please?

Kind Regards


You can check System Preferences/Sound for the proper settings (compare them to the settings on your wife’s Mac). Likewise MIDI Audio Setup. It is possible that the bbworkspace folder is not complete or set up properly. Last but not least, there may be something with the macOS permissions and the BeatBuddy Manager (BBM) that did not transition correctly when you upgraded to Monterey.

Your issue is one that you’ll need help from to resolve. Usually it will involve completely uninstalling the BBM, the bbworkspace folder and deleting the contents from your SD card and doing a fresh download and install. After the re-install has been completed, I would restart your iMac.

Please let us know what had to be done to get your BeatBuddy Manager (BBM) audio back.

I moved your post to a new thread.

Here everything is working OK on iMac (2020) with Monterey 12.3.1 so I hope it’s something in the settings…

1 Like

Thank you, I’ll try your suggestions and sure, I’ll let you know when its fixed. Thank you


Thanks for letting me know. Any tips in getting it working would be great. It worked fine before the upgrade unfortunately. Best, Jonty

Thank you for your help and your quick response. I am now getting some help from support@singularsound which is much appreciated.

Good to hear. Keep us posted on the solution so we can help other users when they run into the same issue.

An update I got some help from Jay and did as he suggested ; loaded a completely blank and new out of the packet SD card. Unfortunately it did the same again. No sound no movement. I decided then to take the nuclear option and wipe my hard drive to return the disc to factory settings. Took a few days to get everything loaded back on and I ordered another fresh SD card. That arrived; I downloaded a fresh copy of the library from the singular sound site, a fresh copy of Beat Buddy Manager and…. This time it worked! Everything is as it was and working perfectly fine.

Got to say a big thank you to Singular Sound. Great support and more than I expected. Jay’s help gave me the confidence to try this approach.


1 Like