No bottom line of text

I just updated the firmware of my MIDI Maestro, and updated default modes, and now none of my screens have any bottom row of text! The little grayish boxes indicating that text CAN go there aren’t even showing up. (see attached picture)


Hey there,

If you didn’t yet please power cycling the unit (turn off and back on)

If this does not fix it or otherwise, please reach out to with your issue but my suggestion would be to try writing the firmware, default mode, and custom mode again

Thanks for reporting

Also, make sure you are using the latest version of the app (1.6.1) when doing so, check the App Store or the Google play store for the latest version.

Thanks for your help! I just updated the firmware and the 2nd line came back. Should I now Update Default Modes, or leave it as is? Thanks again for the help.

Okay, problem NOT solved. I updated the firmware and that gave me the 2nd row of text back. However, when I restarted the unit, the bottom line disappeared again. Help??

Please contact Support,


I just updated the firmware on my pedal. Upon finishing the update, the top 3 screens displayed EEPROM Invalid. Nothing on the bottom screens. I turned the pedal off and back on, and still got the same display. Updated the Default Modes and still had the same screen displays upon completion. This time I turned the pedal off, disconnected the power and let it sit for a couple of minutes. After plugging it back in and turning it on, the pedal displayed 1.1.9 in the bottom left corner. I’ve run across this problem several times and usually just turning it off and leaving it alone for a while got things working properly.

Let us know how it turns out for you.

Please do reach out to support, there should be no need to ‘wait’ to allow the unit to be ready

These are the proper steps for updating:

  1. Update the MIDI Maestro App to the latest version in the App Store or Google Play Store
  2. Turn on your MIDI Maestro and enable Pairing Mode (hold the pairing button on the back of the unit for ~1 second). A blue LED will flash once the pairing mode is turned on.
  3. Go to the Hamburger menu in the app (top left) and select the Update Firmware option. Once the app has established connection you will see the MIDI Maestro blue Pairing LED stop flashing and turn solid blue.
  4. Allow the process to finish, the app will show the progress. Do not close the app, put your phone to sleep, turn off the MIDI Maestro, or change to another app while this is happening or you will need to restart the process.
  5. Once the firmware update is complete, you must rewrite the default modes to the device, the MIDI Maestro may turn off the BLE Pairing Mode automatically, turn the Pairing Mode back on again manually. Your MIDI Maestro screens may read EEPROM INVALID, disregard this.
  6. In the app, reopen the hamburger menu and select the Update Default Modes option. Allow the process to finish, the app will show the progress. Do not close the app, put your phone to sleep, turn off the MIDI Maestro, or change to another app while this is happening or you will need to restart the process.
  7. Once the update is finished, power the unit off and back on again to see the update take place. You can verify the current loaded firmware on the MIDI Maestro on the bottom left screen of the main menu.
  8. Optional: Load in the custom mode currently open on the app by pressing the Upload to MIDI Maestro button in the Home screen.

Thanks for the suggestions. I’ve tried everything you both mentioned, but as soon as I turn the pedal off and back on again he bottom row of text disappears. BTW I am a techno nerd, so I do know fairly well what I’m doing when it comes to this stuff (yes, I tried unplugging it and made sure it has power, LOL). I’ve reached out to support but haven’t heard anything back yet. And since we’re creeping closer to the weekend I’m getting more nervous. Again, thanks for the help, and I’d appreciate any other ideas. Cheers!

Please circle back and let us know what it took to get it working.

What do you get when the switch the Modes?

I absolutely will let you know when I hear back. Switching modes I still get only the top line of text. You said you’re encountering something similar, correct? I hope it’s a glitch and fixable with an update and not an error in the pedal. I’ll let you know what happens.

You might want to let Support, know which version of your phone’s operating system you were using.

I was using iOS 16.5 and although our symptoms were sort of similar, I was able to resolve mine. Hopefully you’ll resolve yours too.

While you wait, here’s something else you can try: delete the MM app from your phone and then download and reinstall.

Place your phone next to your pedal and go back thru the process to install the firmware and Default Modes. Follow the instructions Brennan posted here MIDI Maestro Firmware 1.1.9 and MM apps 1.6.x and NYHC reiterated at the next to last post in that thread. Good luck—I’m sure you’ll get it installed and working.

I experienced this when I rigged a 9v battery adapter to the power input. I thought the issue was the 9v battery was not putting out enough power but power cycling a couple times seems to bring it back.

I just downloaded the firmware from my Android phone app to Midi Maestro ( Brand New ) After which I recieved an error message of EEPROM INVALID on my three top screens. When I first turned it on without downloading the Phone App everything on all of the screens was properly displayed. I cannot get the operating screen to reset. I cannot get the EEPROM INVALID to go away. I’m thinking I should never have installed the app on my Android. It is a very frustrating first impression of Midi Maestro!

Try following the step-by-step instructions here: Maestro displays EEPROM INVALID after updating - #5 by BrennanSingularSound

Other users had a similar issue and they resolved it by completing the process and installing the Default Modes following the firmware update.

1 Like