No Click on Aeros

I’ve tried to get Aeros to give me a click intro, but it has never worked. I get no intro on first recording, or second recording.

Have you accidentally got it directed to aux out only?

The click is directed to Aux Out yes… is that wrong? I have nothing plugged into main out. But the Boss 505 worked fine using phones socket. I figured that Aux was the same as Phones.

No. That sounds like you’re right. I was hoping that you were using main out and had click directed to aux out with no way to hear it.

Only other things I can think of trying: listen to main out anyway. There might be a bug. Make sure click volume is non zero in song settings.

Didn’t know click had a volume setting, I will look for it.

Hey any updates here? Click should always be there as long as you have Click volume level up, the click is set to play, and it is routed to the same output you’re listening/monitoring from.

I still get no click. I’ve tried everything I can think of. I’ve tried a different cable as well. Do you have to have Beat Buddy to hear the click? I don’t have Beat Buddy, or Maestro. I am still going through Aux, I can hear both tracks play back, but no click. I set the click volume to 100. I tried 2x2, and 6x6. Intro measure 1, intro measure 0. Click after first run yes, click after first run no. Nothing worked.

Did you mess around with the other click settings in the global settings? Maybe one setting there is set to something that is disabling the click?

Could you explain your audio routing from Aeros so I can better understand the scenario?

Some things I’d check off is that

  • there is a cable running from the Aux Out jack to a mixer/PA/Headphone amp
  • the Click setting is set to route to Aux Out
  • the volume is set to ~50 to avoid being too loud at first
  • Blank song part is in quantized mode
  • In Song Settings: Count in is set to at least 1 bar.
    Are you following all these steps and this is still happening? I ask because I can’t reproduce it


Everything is the same as that. I am running out to Monitors (like speakers). I have also tested it into a mixer… no click. The mixer was just a test, because the mixer is going back into the Aeros, and that would create a feedback loop if it was recording what it was hearing, and then playing it into what it is also hearing. So I use two different listening devices so as not to record what I am hearing.

graph LR A[Genos] -- L Input / R Input--> G[Mixer] B[Hydrasynth] -- L Input / R Input--> G[Mixer] C[MakeNoise <br /> Black And Gold] -- L Input / R Input--> G[Mixer] D[Octapad] -- L Input / R Input--> G[Mixer] G -- L Input / R Input --> H[Aeros] H -- Aux Out --> I[Monitors]

Maybe I just have a broken Aeros?

Since the click is software generated it seems really really unlikely to me that everything else would be functional but the click not if the unit really were faulty. That implies that is a settings problem, or it’s a bug. If it’s a settings problem: well the setting just needs tracking down. If it’s a bug, then the exact environment that activates the bug has to be found so it can be reproduced and fixed.

Can you post photos of the routing settings and the click settings. Could you confirm that you have listened to the main output too, not just the aux?

I haven’t listened to the main Output, because it will only go to the mixer, and that would create a feedback loop. I don’t have a cable with two 1/4 jack to two phono. I only have cables for the Aux. Monitors require Phono which is 1/4 stereo out to two phono… I have that cable.

Another thing I will look at is Midi In. I am using midi In to sync my Aeros to the beat of the Yamaha Genos.

I tested the main output using a single jack in Mono, and set the Aeros to mono, there was still no click.

I changed all of the settings to Main, and Aux, and there was still no click.

I took out the Midi In cable… no click. I turned off all the midi routing… no click.

I set the click volume from 100% to 50%… no click.

I tried Start Immediately. Start at end of loop, start after a measure… no click.

Taking photos would be a bit of a pain with a scroll wheel.

Is the click stereo through both speakers? Does it use a Midi chip? Does it use a chip that could be broken?

Could you confirm you have Firmware 3.1.18. I think I caught a post saying you had done it. Reading through the manuals firmware changelog it appears the function of the click may have had some fixes in some updates. May not be the reason, but worth a look maybe.

I have done the last two Updates, that’s when I got my Aeros. Could they have accidentally skipped the click fix in the last two updates?

I would believe all revisions would be included in the recent update and none skipped.

What is your MIDI Start setting set to?

You may want to reach out to but if you could send me a short video of you scrolling through your device and song settings that would be very useful!

@Pincho_Paxton Please take a quick photo of how the following settings are set -

Under main settings:




Under song settings:

QUANTIZE TO MEASURE (if this is set to OFF, click track will not play)