Only Name Appears on Beatbuddy Screen

Hello! I’m trying the newest firmware, and I’m coming across this issue where the name of the drum pattern appears on the screen of the Beatbuddy. When I press the pedal, the song doesn’t start. This occurs after I’ve played to one song and want to switch to another drum pattern. If I take the SD card out and put it back in, it works again.

Hi there, what number firmware are you using?

Hi! I was using version 4.1.3.

Actually, the problem seems to have been fixed after a while. I think it turned out to be an issue with the hardware. What happened was that the next day after I made the post, the Beatbuddy screen started saying the SD card was invalid. This didn’t make sense to me since I had just bought the new SD card. I remembered in some other post that maybe some grounding issues might be messing with how the SD card was being read. I kept the power cable attached to the Beatbuddy but did not plug the cord into the wall. I also kept the SD card out of the Beatbuddy while trying this. I touched the plug of the cord to the floor for a few seconds, and then I put the SD card back into the device and turned on the Beatbuddy. The first few times I tried this, the Beatbuddy no longer said the SD card was invalid, but the problem of having only the name show up returned after playing a few songs. The next day, I tried the maneuver again, and the problem has not returned since.

tl;dr → I think it was an electric problem with the hardware that coincided with updating the firmware.