Outtro fill plays fine in Manager...not on the BB

I have edited a beat to change the outtro and in Manager it plays fine but after transferring to the BB card and playing it there, all I get is one beat sounding (as in a single beat) when I press the outtro button on the footswitch.

Can anyone suggest why this is happening? All the correct notes are displayed and play correctly in the manager app, so I am unsure as to why this is happening. And yes, the card has been synchronised.

I’d have to see it, but usually when that has happened to me, it’s a note placement issue – either the fill is more than 4+1 beats or there’s nothing in the first beat of the fill. In many cases, I’ve simply accidentally started the pattern in NOT the first beat (I do a lot of editing, and it happens to me pretty regularly, because, apparently, I don’t learn :slight_smile: ).


  • If your outro is more than 4+1 beats: Add 5-10 bars of silence to the end of it, and use it as a pattern instead of an outro. Add no fills and no outro, and you can just stop your BB after it plays the last beat.
  • if your first beat is silent, you can either do what I suggested above, or add a note to the first beat. I often use a hi-hat pedal, because that feels like something a real drummer would do, but any note – with a velocity of “0” if you want it silent – will do.
  • if you’ve accidentally started the outro on anything but the first beat, fix it. :slight_smile:

Let me know if that works for you. If not, I’d probably have to see what you’re doing.


The outro can be any number of measures. There would be no need to have it as a main loop. It is not limited in length.

Before getting too deep into trouble shooting the song, I recommend you check your pedal settings to verify that your “when playing” setting does trigger an outro. I would also try the song with another kit to see what happens. Sometimes BB will not process very short notes, i.e., ,notes that are only a couple of midi ticks in length. Try to verify that your notes are a minimum of 40 ticks, unless you need shorter notes.

Thanks guys, I will run those tips and get back and advise.

“The outro can be any number of measures.”

Sorry Phil, I’m going to have to disagree here. Anything more than measure length+1 MAY play correctly if you hit the outro EXACTLY right, but more often than not it will not play properly – something gets lost in the translation. And I have not had a lot of luck at all with anything more than measure length+1 generally, timing issues or not.

My suspicion is you have better timing in your feet than I do, and probably slightly different settings regarding the execution timing of the changes, and that may be why we have different experiences. But I can only speak to my experience, and that is that outros kind of need to fit in the box.

It might be your cue fill setting. I have mine set to “next measure.” I often design my songs as Prejam, Jam, Coda. The Prejam is the intro. Jam is main loop 1 and Coda goes into Outro. Also, the other Phil does his OPB songs as Null in main loop 1 and whole song in Outro.

“Next measure” might well be the culprit, because that SHOULD force the outro to start on the 1, regardless of what else is going on. Because I sing, play guitar, drive the drums, and occasionally switch patches, I can’t think that far ahead, so I have mine set to “Immediate.”