Part changing issues in free form mode

This might sound a bit complicated, but I try to explain it:
When one records a couple of tracks in freeform mode, something like drones that fade in and out, it would be great to change parts in the following way: Wait till every track has played out!
Means: A shorter track wouldn’t re-start and probably be cut off in the middle while “waiting” for the longest track to end. This always creates unpleasant and anti-drone like clicks and cuts.

Anyone know what I mean?

Thanks!

In other words, after one loop mute each track until the longest track completes it’s loop and transitions.

A hacky workaround: If you have a midi controller with enough buttons, you can manually mute each one. A lot of tap dancing while you’re thinking more about the next part (and you’d need to unmute when coming back).

Well, anyone has ever used free from mode to build textures that are building slowly and going (intentionally) out of phase? If you use different parts and come back to you first part it gets even worse. The individual tracks/loops start all over the place, only one from the beginning all the rest somewhere in the middle as if they were kind of locked to the first track.
As I said: One option setting could solve this problem and make the looper work for ambient music (with more than one part)…