Pause & Accent Hit are delayed...wasn't always the case

I’ve searched through the forums but haven’t seen a high volume of issues like this.
I just got to Firmware 3.2 and then moved to 3.6 to try to remedy this, still a problem. Never had this issue prior to that…but I wasn’t using the pedal as seriously as I am now.

Currently, with my external footswitch the pause/start or accent hit have a delay.

It’s not “on release” as you can set for the main pedal but delayed when I push it down.
It can’t be normal, nearly impossible to hit an accent on a a particular beat.
I’ve tried the footswitch calibration in the settings menu - no luck, it does read as momentary. I also tried deleting everything on the SD card then copying my files over again.

Does anyone have any additional ideas? I’m trying to sell some guys on using this lately and the limited functionality is not helping my case.

Try reverting your firmware to 1.8.5 to see if the delays continue.

Thanks I will give that a try.

I’m assuming there is a reason you specified that version - any idea where I can find it?

Well, I fixed it…I’ll share to clarify for anyone that gets lost in similar troubleshooting like I did last night - just know that it was not the fault of the Beatbuddy or the firmware. I should have discovered this very early by troubleshooting more thoroughly with a direct signal out from the BB.

So I downgraded to 1.8.5 per persist recommendation and it seemed to have been fixed. Then I moved through some other songs (and had changed my output signal chain) only to find it was still occurring. I then realized when I ran directly into headphones or from the L or R out into a speaker it was working. When I ran from 3.5 into the aux in of my TCH PlayAcoustic, the accent was delayed.

So I dug deeper and found that my PlayAcoustic aux input was set to “tracks” and not “live”. Switched that back - problem solved no matter the cable or the firmware. As it turns out, the entire beat was delayed but I was only perceiving the accent as being late because I was controlling it in the moment.

It is common sense - I should have started with a direct signal chain. It didn’t occur to me that there would be any setting on that PlayAcoustic that would be altering an incoming signal like that.

Hoping this might help anyone who runs into a similar situation.
Thanks Persist