Pigtronix Infinity Looper - Wish it would sync timing of the STOP button too

i’m using the Infinity Looper with the Beat Buddy (and a whole bunch of other stuff!).

as we know, when we use MIDI to sync the devices to the same clock, you can press the LOOP1 button to start the loop (actually you want to press it just before the start of the measure), record your loop, and then you can press the LOOP1 button again to close the loop at any point before the next measure. on the DOWNBEAT of the next measure, the loop will close to make a perfectly timed loop.

so again, you can hit the button early to close the loop, and it will close it on the downbeat of the next measure. awesome!

but sometimes i want to record a loop but NOT play it immediately. without the MIDI sync and just using the looper by itself, you can do this by hitting LOOP1 to open the loop, record the loop, then when you are done - and in good timing - you press STOP instead of LOOP1 again. this will save the loop, but not play it. then later you hit LOOP1 to play what you recorded (but never heard). this is very effective in many situations.

i was having the hardest time trying to figure out why my recorded looper on the Infinity Looper were playing back at slower speeds and just sync’d. i thought it was my Master Clock devices, or the midi cables or this or that.

turns out that when you have the Looper sync’d via midi and then end a loop recording with the STOP button, as i’ve described above, the resulting loop is NOT the right length and therefore the Looper tries to Varispeed the loop to match. this is actually pretty irritating, but it’s how the Looper was designed.

regardless, it was the fact that i was using STOP to close the loop. i know this is more of a Pigtronix question, and i’ll probably email them and link to this post. but it would be great if the STOP function could behave just like the LOOP switches only when closing a loop that is currently being recorded:

MIDI Sync, open a loop with LOOP switch, record, close the loop with STOP switch early, but the Looper continues recording for the full bar and stops on the next downbeat.

for now i’ll have to use the LOOP switch to close the loop so it’s perfectly in sync, then quickly double press the STOP button to stop that loop.

anyone else experience this?

Hi, seven8time. The Varispeed issue sounds similar to what @RaineMakerMusic is running into and has been working with Mike at Pigtronix. Don’t know if Pigtronix has made any progress on fixing this. Please let the forum know what you find out.

Anyone ever find the solution to this? I’m using the infinity with the beat buddy and continue to have this issue regularly. Can I turn off Varispeed altogether from the windows app? Thanks.

I checked for an Infinity f/w update earlier this morning but it does not appear to have been updated.

According to David Koltai in an e-mail exchange, the Varispeed is always available and cannot be turned off.

I agree with seven8time - I would like the STOP button to close the loop exactly like the LOOP button does. I’m at a loss on how the current functionality is even useful. Anyone reach out to Pigtronix on this lately?


Hmm. From the manual:

“Stop - The Stop footswitch closes loops and stops loop audio at the start of the next measure after the switch has been pressed.”

This doesn’t seem to be true. :-/

No doubt these are annoying issues and I hope users have been contacting Pigtronix to share their observations. Ever since hemogloben and Ben Artes departed Pigtronix, refinement and bug-squashing for the looper have stopped.

1 Like

Going back through some of my old emails, I found the thread below. I’ll resend to Pigtronix to see if there is any hope of fixing this.

Sent: Saturday, December 24, 2016 4:31 PM
To: pigtronix@gmail.com; info@pigtronix.com
Subject: Re: Bug in MIDI sync for 2.11

A little more testing done with MIDI sync and 2.11. It seems that when the Stop Mode is set to Trail, pressing the stop footswitch while recording loop1 stops the recording immediately and pitch-shifts the loop. If the Stop Mode is set to Full, then pressing the stop footswitch while recording loop1 will stop on a measure boundary, and the loop is not pitch-shifted. Switching between loops also changes on measure boundaries, so that’s good too. Not sure why Trail mode behaves the way it does on recording, but at least I have a workaround. It’s a little more of a pain since for non-MIDI series looping you have to use trail mode, but series looping with MIDI clock you have to use full mode. Anyway, it would be nice if this were consistent. Or I’m missing something. BTW, I think I thought it was not an issue with 2.03 because it was probably in Full Mode when I tested. The two versions behave the same regarding recording loops with midi sync.

Merry Christmas/Happy Holidays,

On 12/21/2016 5:38 AM, John Strobel wrote:

Hi David,
With version 2.11 of Infinity, the stop button does not close a loop on measure boundaries but instead closes the loop immediately, which causes the loop to be either pitch-shifted (in the case of loop1) or just lose sync (in the case of loop2). I reformatted and retested with no change. I rolled back to 2.03 and tested; with 2.03, the loops always close on measure boundaries . Since this is how the stop switch function is described in the manual (section 6.3, Commands that Sync to MIDI Clock), it looks like this got broken after 2.03. This is kind of a big deal, because with 2.11 there is no way to close a loop without immediately replaying it (play/rec/dub switches do seem to respect measure boundaries). I hope this gets fixed soon. FYI, I did speak with Mike (your MIDI guy) yesterday about this, although he was under the impression that closing the loop immediately was how it was supposed to work.


A workaround in 2.11 is that if you set the stop mode to FULL, then it behaves like you want. It seems that when the stop mode is set to TRAIL, the loop closes immediately when the STOP button is pressed. Quirky, but a workaround.

1 Like

Hi, thanks for the trick. I had some mail exchange with Pigtronix last week about this bug and the answer is that they will not fix it for the Infinity 1 and you have to buy Infinity 3 instead… Here is a part of the answer :

"The new Infinity 3 syncs to midi clock with almost no issue. This has been an update that we added to the new Infinity 3. "

"I apologize but this was one if the improvements made to the Infinity 3. The Infinity 1 will sync but it is not instant like the Infinity 3. The hardware was upgraded in the Infinity 3 to allow for much faster midi syncing. "

Too bad.