Playing 3/4 time midi files

I am pretty adapt at midi drum programming, so I am building a lot of basic beats from scratch and dropping them into song parts. However, when I build a 3/4 time midi file, it loads ok, but BB still plays the measures as if it’s 4/4. In other words, a two bar 3/4 time file will play the two bars (6 beats), but then BB just goes empty for two more counts before starting the loop over again as if it was a two bar 4/4 loop. If I load a 3/4 time file from the BB songs, the count is correct, and the virtual bar indicator only ticks thru three counts per bar.
What tells the BB to play in 3/4? Is there some midi code I’m not including?

I use Reaper to create my midi files but have problems with different time signatures when exporting to midi and using in BBM to make song. In reaper it will have 3/4 time sig but after saving and opening in BBM it will be in 4/4. What I have to do is open the saved midi file from reaper in another midi editor (I use http://midieditor.sourceforge.net/), Change the time signature in this program and save and it opens properly in BBM with the right time signature.

Don’t ask me whats going on but this works for me.

Thanks for the tip and link I will try to download the midieditor program and give it a go. I use Presonus Studio One as my DAW, and it has a very easy interface for editing midi. Like you, I create beats in 3/4 (or any other time signature), export, then upload to BBM. It may show a 3/4 signature on the file, but plays in BBM as 4/4.

Would be nice if someone could tell us what the BB uses to set time signatures for songs. There has to be some “code” or something in the midi file that lets the program know how many beats per bar to use.

Will re-post if you’re workaround works for me.

I would have thought that it is the time signature in the midi file that sets the time signature.

Apparently it does somehow, but I don’t know how the time signature is “coded” in the file. (It-BBM–really is squirrelly software!) Any file I build in my DAW and export in 4/4 will play in 4/4, but build one in 3/4 or 6/8 or any other time signature, and the BB will continue to play as if the file was in 4/4, resulting in empty beats. This is after I have set the file up in 3/4 and set the DAW to 3/4, 6/8, etc. If I load the file up in the BB midi editor program designed by Charles or one of the other free midi editors (sourceforge), manually change the time signature, then re-save and reload into BBM, the program and BB will read and play the file in the correct time (note that when the files load in the midi editor programs that they also load as 4/4 until changed).

The problem with both of these mentioned midi manager programs is they don’t always read the midi files I have. There is something quirky about those programs as well and they only load files designed to play on midi channel 10. Apparently some of my midi files (I have a lot from the Addictive Drums library) are set to play on a different channel, so you cannot manipulate them in the BB midi editor or in Sourceforge. I can’t figure out how to change the channel setting either, so I am stuck with some non-standard timed files that are not usable outside of the original program. Even with the files that I can use, it seems silly that one has to create, load into another program, re-save, then load into BBM to use the file.:eek:

The other maddening thing about the program is that it will not save and read the wav files created in my DAW. It will load them into a drum kit as samples, play them after loading, but the minute I save the kit, the files are rendered inoperable and will not be played. Other wav files play after saving just fine, but not the ones created on my DAW.:mad:

I know there is another thread on this, but the more I work with the BBM software, the more quirks I uncover.

I’m having similar issues with time signatures other than 4/4. On inspection of the exported midi file from reaper, it doesn’t appear to incorporate the time signature as a midi status message “FF 58 04 nn dd cc bb”. Perhaps the latest version of reaper fixes this. I’m assuming that in the absence of a time signature in the midi file, BeatBuddy has to assume 4/4.